Does anyone have flickering double image with the pimax on the latest beta?

does anyone have flickering double image with the pimax on the latest beta? I tried to search for information under the beta subforum but no one had mentioned it…I tried playing Rec room, beat saber, bullets and more, Creed…and many other games…all those games would have flickering double image problem and my FPS would read maybe 3-4fps at least for a minute or two and then it may or may not fix itself and I would be getting 90fps…my system run on 8700k with 2080ti…tried downgrading back to the last beta version but it is doing that also now so I don’t know how to fix it

the flickering image only happen in VR headset, on my desktop monitor it looks perfectly normal

1 Like

The post before yours also mentions a flickering image with a brief vid.

If symptom is same and an answer appears there.


it does look similiar, but I don’t believe it is light house issue because it only does that in games, it works perfectly fine if I’m in steamVR

what’s weird is, if I click the menu button on my vive controller…the flickering goes away…and when I click it again to go back into games…any of those games listed above…the flickering comes back

Not an outside influence from something like fpsvr by any chance? I’ve seen someone mention another graphical oddity that fpsvr was contributing to last week.

I went back to pitool 109 release and everything is running perfect again, just sad that I don’t get to change the brightness and contrast anymore however

I saw this tonight, in Elite Dangerous. Framerate was set to 72 Hz, SmartSmoothing and FFR were off.

It started when I entered a system with a neutron star. The fancy effects apparently triggered a framerate drop and the double images started. After jumping to a new system, they continued, until I looked at the galactic map and returned to the game. From then on, everything was perfect again. I didn’t need to restart the game, reboot the headset, etc.

It looks like a frame drop may trigger this issue, but a graphics scene reinitialization appears to fix it.

@Sean.Huang, this might be a clue to the problem, in case you’re having trouble reproducing the issue.


Yes, I’ve seen this as well, but only when testing the driver in Skyrim…

1 Like