Do index knuckle controllers work well with Pimax yet

What’s the general up to date view on this (thinking about buying them now to get the free Half Life game). I know there are a few threads on this but they are all a bit old now and dying.


Here’s the last thread I found. Not had any compatibility or lag issues on the apps I’ve tried since going to .180


Thanks, I didn’t spot that thread.

1 Like

Yeah, work fine for me.

1 Like

No worries actually that was the wrong one :grinning:

Guess it doesn’t matter now but I meant this one doh

For me they work well, but you need recent Pitool. 132 does not work, 180 (and I assume later) does work, not sure about 144 as I never used it.

One problem is that Wifi Internet connection gets down. So if you are using Wifi you will probably lose internet connection while Index controllers are on (actually it is not lost but goes down to kilobits per second which is mostly unusable).

1 Like

144 does work with Index controllers.

My wireless TPcast uses Wifi so does this mean that you can’t use the knuckle controllers with TPcast? (anyone)

TPCast uses its own wireless router and the connection to/from the PC to that router is wired, right?

If that’s the case I don’t think there would be issues as the PC isn’t using wireless directly.


I have internet by cable but when the router is On also wifi is On.

If I play VR with Pimax 8K X and Index controllers, do you think there are issues ?

No it is no problem at least for me.


I’m not sure at all, but what others have reported seems to be that it’s when their PC is connected via wireless, i.e. no network cables between PC and router their connection is tanked…

If You’re not using the wireless network card on the PC I don’t see how it should be affected.

I’m thinking the problem might be related to the issues with RGB control software where the RGB controller is using USB and exhausting it with polling requests causing bad tracking.

If (onboard) wireless controllers do the same they might be the reason.

EDIT: It might actually be the other way round. I.e. PiTool/Pimax service tanking the USB port/channel/controller leaving no room for other peripherals on that specific port/channel on that specific controller. This would explain why people have issues with various other USB peripherals and Pimax headsets (note: I also had the issues with my Vive when Asus Aura software was enabled).

Using a dedicated PCI-E based USB card takes that possibility of if the equation and has also been recommend by Oculus way back.

I’m using an Inateck USB 3 card which only the Pimax is connected to and never have any issues.


Thank you to both for the answer

1 Like

I disabled RGB controllers after reading about this theory - it did not help.

As for USB theory, not sure, but I tried also with direct antennae (e.g. not USB antennae which I normally use) and it still went down.

Also Pitool/Pimax by itself is not a problem, the moment I turn Index controllers off, the bandwidth gets back again (e.g. no problem playing Elite Dangerous with gamepad and base stations, no problem with Dirt Rally 2 as well).

The problem only manifests while Index controllers are turned on. Of course it might be connected to Pitool/Pimax service in this scenario (I don’t have other headset to try if it would be problem running with Vive or Index).

1 Like

It does indeed sound like a PiTool bug then. Might be their Knuckles driver implementation that’s bugged as they’re intercepting the controllers before issuing to SteamVR.

This is probably due to the ability to run Oculus games without SteamVR.

What they should do IMHO is to let SteamVR handle the controllers unless games are started directly from PiTool in Oculus mode.

The only issues I get with the Index controllers is that the controllers aren’t detected correctly from a cold boot or after restarting PiToolServiceLauncher while the headset and controllers are powered off.

If you power the controllers on before the headset, the controllers will show up however the battery indicator on the controllers do not display in VR.

On the other hand, if you power the controllers on after the headset, the controllers are not detected at all until you restart PiServiceLauncher again while the headset and controllers remain powered on, after which the controllers will be detected and the controller battery indicator status will also be displayed correctly.

Something for @Matthew.Xu to be aware of, since it’s the most annoying part of the Pimax experience.


Yes I found the same, although I restart the headset instead of the service to get the same result :+1:


I have two issues.

First issue is that the controllers are constantly powering down. I’ve gone thru all of the SteamVR settings but there is something in PeeTools that over rides the power down settings in SteamVR and shuts them down in mere minutes. It’s not consistent, either. Sometimes my controllers will stay on and sometimes they’ll shut down as I’m using them. Charge level seems irrelevant. Once in game, they work fine, but it can be a bit irritating if you put them down for a minute. Seems as if it might be a ‘sleep’ function based on movement of the actual headset itself, rather than controller movement because it will shut them down while the controllers are actually moving, if the headset isn’t.

My other issue is that it doesn’t always see both controllers when starting up. I always power up the headset first, then the controllers. If I start SteamVR before powering up the controllers, then, sometimes, SteamVR won’t see one of the controllers (PeeTool won’t see it either). If that happens, I go into PeeTools and reboot the headset. When it’s finished cycling, I’m good to go!

Other than those two minor issues, mine work great!

1 Like

Thank you for your feedback, the team already knows this issue.
We discussed with the development to better optimize the compatibility with the index controller.
Thank you