Disable the internal GPU

Hi all,
i have bought a Laptop MSI Katana 17BVGK-078 with an RTX4070. It has an USB-C Displayport and i’ve bought an additionally and Club3d converter. On my first tests the Pimax Tool (latest Version) says that i have to disable the internal GPU. I’ve installed MSI Center and change to discrete mode tahts disables the internal GPU. It is not shown in Devicemanager and NVidia Panel anymore. On Physx settings of NVidia the USB Port is shown on RTX4070.
But the Pimax Tool is still displaying that i have to disable the inetrnal GPU, but its disabled.
I have created an Support Ticket but i don’t get any reply so i want to ask here if somebody has an idea.

Thx forward.

1 Like

Not sure. Have you checked the bios for an option to disable igpu?

1 Like

Yeah, might to check in the BIOS settings.

Hi, i have changed the Headset Frequency to 75Hz and now its working.

Owned the 8KX?

Yes i have an 8kx

My first thoughts that the Pimax is working on my Laptop, is wrong. Its only working for some seconds and than shuts off. I had the same issue on my Desktop Pc several month, too. I have disabled the internal GPU in Bios and than everything was working. I have disable everything imcould found in Bios of my Laptop to disable the internal Gpu, but it wont help.
The so called ‚moon landscape‘ is showing for nearly 20 seconds and than the headset switches off (black display).