Created Account 2x says incorrect user name or password

@anon74848233 So what’s going on, I created a user account twice, once when I pre-orderd my 5K+ and today. When I tried to contact support back then and again now it tells me incorrect username or password. When I tried to reset password it tells me no such account exists. So I can’t contact Support to find out the status of my order after 5 months of waiting. I was told 120 days till shipping but that has long past and no word. After 5 months I would at least like some kind of info about the status of my order for some reassurance that I will eventually get my 5K+, order number P1668. I couldn’t even cancel and get a refund if I wanted to, this is very frustrating customer support when you can’t even contact them. Help Please


I think you might be able to try this, it worked for me.
It asks for your username but actually you need to put in your email address. That’s what worked for me.

1 Like

No luck tried that before and now and it still does not work.

I can not long in either. When I say forgot password and enter my email it says my email does not exist

Welcome to the club. I managed to send them a message through the contact us off their web site and hope that that gets a response.

Did you use any special characters/etc in your username/password?

You need to create a separate support account even if you use the same email address.
I dont think account you use to order and the one you use for support are linked.
So you need to register for each one.


Thanks for your reply omar, I did try to create another account through the support link but the create account link did not work for me, that may have been a problem on my end at the time but I will try again. And if this is the case that you need a separate account for support I think they should make that clear as I see other people are experiencing the same issue.

In case you haven’t created any tickets yet, you can try creating a fresh account with a different email address. Maybe passwords without special characters is essential(my first password had them, reset requests not).

After trying and waiting for one month creating a functional account finally worked.

I’m having the same problem, made an account yesterday. Submitted a ticket and now today I can’t login nor recover password because that email apparently doesn’t exist. Not sure how do I now check on my SUPEN ticket.