Controllers not appearing all of a sudden, and giving me weird error when trying to!

Yesterday controllers were working fine. However today, i tried using different usb extensions to see if they work (they didn’t), so when i switched to the normal usb port i was using without extensions the pimax display and audio worked again. But now, controllers aren’t appearing lol… Tried different usb ports, no difference. Then i tried pairing from pitool, and it gave me this weird message in the pic below. What to do?

@Sean.Huang @PimaxUSA @Matthew.Xu

Restart the pilauncher service

did that, also uninstalled pitool and downloaded the latest one, nothing. Still giving me that weird (Not enough dongles detected" error whenever i click the “pair controller” button in pitool

Hmm, guessing by your picture, i believe that the USB drivers might not be installed.

Can you take a picture of your device manager ?


restart fixed it for me :joy:



Aaargh, just one controller shows up. The other one turns green as if it connects but it doesn’t show. Restarting pilauncherservice is not helping


1 Like

i uninstalled pitool, changed usb ports, restarted pc, installed pitool again, turned on the headset using the power button, then worked again

1 Like

I hooked up my 5K+ again and it needed pairing with the controllers, pairing both controllers with the 5K+ is working.

I will now switch back to my 8K again and see if that goes well too.

Result: Nope. Now it doesn’t want to pair with anything, I get the ‘No enough dongles’ message immediately.

1 Like

Had to restart pc too to get me some dongels freed

1 Like

Weirdest sh*t, not enough dongles lol.

Poor dongles, all filled up but nobody to talk to.