Client v1.12 findings thus far

Hoping to make things better on my 4090 I installed the v1.12 client today. Early testing suggests is might have resolved the “momentary frame glitching” issue that I experienced rarely but which I believe I saw others report as being pretty common. At any rate, TWDS&SR was giving me those occasional hiccups on PiTool but client 1.12 seems to have resolved it (only 30 minutes play at this point, so I could be wrong.)
A major problem however with Lone Echo, which is lacking lighting in the 1.12 Client. I know it worked prior to the update because it is a title I come back to routinely, and it’s the title I test each Pimax software release with to be sure Oculus mode is working properly. Lone Echo 2 looks just as it did before, but ambient scene lighting is absent in Lone Echo, making the title unplayable as most of every scene is just black.
I see references to a v. 1.13, but am unable to locate that version to test, and the update button in Client tells me I’m up to date.
I’ve also noticed that the entire client layer is essentially just a bunch of extra steps. Since launching directly from Client does not apply the per-title settings, you must dig into “Device Settings” anyway, which essentially is just PiTool, and launch from there. Kind of pointless to add those extra steps and I would rather just have an updated PiTool.
Finally, the UI appears to have only a dark mode, which is much harder to read than the older, traditional mode, was in PiTool (Pimax devs; just google “why is dark mode harder to read” and you will discover why you need to include a traditional mode. You can keep the dark mode for people who prefer ‘wow isn’t that cool’ over ‘look, it’s readable’ - but please don’t force everyone to use a mode that’s more difficult to read.)


I haven’t delved more recently in Client. But past versions was just a launcher in top of pitool; however if you run the pitool exe direct the interface in chinese. Reminds me of the roll out of Windows 95 which was Dos 7 with a auto windows launcher in the Autoexec.bat to run Windows v4.x


I have definitively tracked the source of the incompatibility with Lone Echo (1) to Pimax Client 1.12 and 1.13 (I have not tried older Pimax Clients). I reinstalled PiTool .284 and Lone Echo worked properly again.

Now trying to figure out if there is any benefit at all to moving to Pimax Client - at first I thought it resolved some issues with the 4090 cards (occasionally momentary hitching, glitches, multiple frame ghosting), but all Client seems to have done is trade those issues for different ones (longer but less abrupt interruptions).

Testing mainly in Alyx and TWD since those run so well and are known quantities.

Anyone else managed to totally eliminate glitching on the 4090s with Pimax HMDs? Mine wasn’t too bad for a long time, but recent NVIDIA driver updates (I think) has caused them to occur more frequently and it would be great to eliminate them.

1 Like

Don’t have a 4090, but can say I haven’t seen any reason to move beyond Pitool 261 for my 5K+.

Further testing seems to indicate title-by-title differences between PiTool and Pimax Client, with far more problems overall with Pimax Client than with PiTool .284. Problems included some games not working properly or well. In addition to Lone Echo being broken, the performance in Assetto Corsa diminished by a massive 25% and performance in anything run through vorpX also suffered massive performance issues when using Pimax Client. A handful of titles have tiny improvements, but these small gains were dramatically outweighed by massive drops in other titles. The significant UI hurdles are also a barrier to accepting Pimax Client as a viable way forward.

So unfortunately, I’m back on PiTool .284 with zero intention of moving to Pimax Client until it becomes a necessity.

I’ve said it before and I’ll say it again: Pimax, your software has become so bad that it is destroying the usability of your hardware and driving away customers.


I can also confirm some performance drops with client.

I’m back to Pitool too, but that doesn’t bother me. I actually only used the client via the device option, because I like to check the settings before the game starts.

wich version did you go to?

Hello, I am in the same situation as you.
FPS drop, GPU usage below 80%! Back to Pitool 281, everything is back to normal

1 Like


… chars …

1 Like

Interesting. Does the most recent versions of the pimax-xr/open-composite/openXRtoolkit combo work well with older pitool versions?

I’m thinking about 271 witch, if I remember well, worked fine on my 5k+

While it is great that we can (with considerable struggle since Pimax refuses to keep a proper repository of PiTool revisions) install older versions that happen to support whatever hardware we currently have, it is not a functional roadmap for the future for Pimax. Producing software that’s so bad we legitimate can’t use it means that all of our Pimax products are threatened with unnecessary obsolesce. What will we do when Nvidia or AMD push a video driver that isn’t compatible with older revisions of PiTool (and won’t be fixed, because the problem is “you are using an old version” and because Pimax is too small to be bothered with anyway)? How about when Microsoft pushes an update that isn’t compatible? Steam?

Ultimately Pimax needs to get their current software revisions good enough to actually use again. Pimax Client is bad, really bad. And Pimax has yet to remove the catastrophically terrible 1/3 refresh smoothing ‘feature’ that everyone (I think) wants removed.

I’ve seen nothing, absolutely nothing, that convinces me in any way that Pimax has any interest in fixing things.

Keeping my fingers crossed that other companies come along to inhabit the wide FOV marketplace.

v1.13 is the same perfomance drop ?

Yes. I ended up on v1.13 and the performance drop is considerable.