Change super sampling in steamvr has no effect

No matter what super sampling I choose in steamvr it doesn’t change the resolution inside the hmd. In the steamvr window it shows what resolution it should be but when I play for example pavlov it doesn’t matter if you have ss on 20% oder 500%. Screen looks the same and fps is also the same. Even changing quality settings in Pitool from 1 to 1.25 seems to have no effect except numbers in steamvr video settings change. But inside HMD…nothing.

I am using a Pimax 5k+
16bg ddr3
GTX 1080
Win10 64

But I can’t imagine the HW causes the problem. It must be something in one of the software or firmware.

Or does have SS in SteamVR no effect at all and only PiTool settings count? But whats with the numbers in SteamVR? Can they be completely ignored?

There is an upper limit, which defaults to 4096 to the side of the bitmap; If your supersampling results in higher numbers than that, they will be normalised to that permissable range, without this reflecting in what is shown in the settings window.

It can be increased by editing ‘[steamvr]/“maxRecommendedResolution”’ in /Steam/SteamApps/common/SteamVR/resources/settings/default.vrsettings.json.

That file is not intended for user settings and will be overwritten every time SteamVR updates.

One can also add the entry to ‘/Steam/config/steamvr.vrsettings.json’, which does comprise your user settings, but it seems SteamVR does not allow that key in that file, and will remove it next time it writes it.

Note that any SteamVR supersampling is a multiplier on top of the render target size pimax’s software asks it for (…and which may already have been reined in by the 4096 limit), so if you’ve got x2.0 quality set in PiTools, and supersample in SteamVR too, things will get out of hand really quickly. :7

(EDIT: Also: Some games (notably Unreal Engine 4 titles - at least all older ones) seems to either ignore SteamVR’s recommended render target size, and substitute their own; Or in some rare cases have a dynamic supersampling ratio, which scales up and down based on performance results from recent frames.)

1 Like

Ok now I know the limit but I don’t even see a difference between lower resolutions. In my vive I could instantly see a difference between 120% SS to 160% SS. But in Pimax the resolution from 20% is the exact same as 40, 50, 60, 70, 80, ect. That was my point. Nothing changes, not even in PiTool as far as I can tell. With the first PiTool Version back in…februar? I instantly could see a difference between Pi 1 and Pi 1.25

Now it seems there is a default setting and I can’t change anything in PiTool nor SteamVR.

Also what is 4096 refering to. The x or y resolution? I am not a technic guy. So pretend you have to explain it to a 5 year old…maybe not that harsh but, well. :wink:

edit: I did some testing with fpsVR and changing pitool and ss in steamvr definitly have an impact on the fps. But still from the very lowest setting to the a more higher setting I barely can see a difference. And I am sure in the “early days” of the pimax, like februrary and the older pitools this was way more noticable.

I would assume whichever hits the limit first; After that, the other would presumably be scaled to the proper fraction thereof, that preserves aspect ratio. Could be wrong, though. :7

I have no idea what is happening in your case in general, but note, after some googling, that Pavlov (which you used as an example), specifically, is based on UE4, games built upon which, as I mentioned in the addendum to my previous post, are rather infamous for totally ignoring SteamVR settings, and leaving you having to use in-game SS options, if provided, or if there are none: Edit r.ScreenPercentage, or sg.ResolutionQuality in the game’s .ini files (which may or may not work)).

Now; I have come across a lot of these older UE4 titles, that have taken the PiTool resolution, and become totally unmanageable (tens of seconds per frame territory), until that setting has been reduced to minimum, so PiTool quality should “take”, at least, and I guess I assume your settings have worked for you with Pavlov previously (?), but…

1 Like

Maybe its something in the newest steam vr version. Time will tell. Maybe some more people got this “issue” and can reply here.

For what it is worth, I just fired up Skyrim, with the latest SteamVR beta, first with 20% and then 200% supersampling, and everything seems to be working fine on my end, at least… :confused:

1 Like