Can someone upload Firmware v1.0.0.236 and can I update manually?

I’m getting very irritated with the PiPlay app. It simply does not work, refuses to connect to the internet, and refuses to see the headset.

I just want to flash manually. Is it possible? I’m simply looking for 2k resolution for movie watching, I don’t care about games or anything else.

I have problem when i check the box for 2k resolution, after that, it wont find my pimax headset any more…

Without checking , works fine.

Its possible to flash manually. I don’t know where you can download it. I think you will need to ask PIMAX Support.

You can download it directly from their server: [Removed]

Upgrade tool here:

I’m not sure that you should kill the service though. Try it first if it doesnt work, reboot, dont kill anything and try it again

BTW if you just want 2k ,you can run pix.exe on this forum. Or you can do it manually by installing a hexeditor and then open C:\Program Files\Piplay\PiConfig and then change the first 00 into 01. Then flip to pimax mode and back to extended mode and you should be in 1440p.

The only option I have is Extended. I tried pix.exe but I’m guessing because I use integrated graphics it didn’t do anything. Resolution was still locked to 1920x1080 in Windows display settings after installing Pix.

Hehe yeah it doesnt work on integrated graphics, I’ve tried it myself. I then bought a 1060, they’re not too expensive.

Yea, but it worked fine until a few days ago. I just tried upgrading the firmware with the tool. I was able to successfully put the Pimax into DFU mode, but the firmware flash doesn’t do anything. It also gets stuck in DFU mode and I have to pull it out using

DfuSeCommand.exe 0 return

in command prompt. I grabbed what appears to be the DFU driver off of the internet but that didn’t help with anything.

I just want to upgrade this firmware.

Yeah I had the exact same thing on integrated graphics: worked for a few days then just stopped working altogether. I never found out why, I just bought an 1060.

Anyway if the headset doesnt even get recognized I’m sure FW flashing will fail too.

In theory pimax should be able to support integrated graphics. But I guess most people who buy this card will want to use it in combination with a NVIDIA or AMD, so I wouldnt get my hopes up to receive future support for integrated graphics.

BTW, what makes you think it would work better with the new beta FW anyway ? The whole 2k support is not a FW thing. It’s been there already all along, they’ve just put it into their latest piplay software too now.

I’m hoping that with new firmware and option selected in PiPlay I can get 2560x1440.

I’d be highly surprised. The 1440p option has always been there, it’s using the first byte in the config file to enable it. The only thing that changed (I think) is that they’ve now added an option in the piplay software to flip that byte withouth having to use PIX.exe to do that. So they just made it ‘official’ now by putting it into their software.