Can anyone confirm if this is a bug or something on my machine? (NMS)

So I have another post on this topic that some of you might’ve seen, but TL;DR is that if Parallel Projections is turned off, the Controllers freak out and don’t work right (like an old school turbo mode).

At least for my machine, I discovered that this happens when either Pitools quality is less than 1 or when SteamVR SS setting (global or NMS) is less than 100 (keep in mind I haven’t tested having either greater than 1/100, but increasing either would only worsen performance).

Now, I’ve seen other posts of people saying they play without PP, so I just want to confirm if anyone is experiencing anything different than one I describe above when not using Parallel Projections.


I’ve played with PP on and off with no issues. Which controllers do you have? never seen such an issue, it sounds like it’s something specific to you?
What do you mean by turbo? the old autofire you got on joysticks?

Yeah - like autofire on joysticks. If I try to fire my weapon, the weapon appears and disappears super fast and nothing happens. I can’t interact with menus because they appear and disappear too quickly.

But to be super clear here - the question is whether you’ve used PP Off with SuperSampling turned down below 1 or 100 and your controllers still worked fine? I’ve tested with either Index or Vive controllers and both have same issue.

Meant to reply directly to you. See my comments above.

OK tried PP off in no mans sky, Pitool render scale 0.75. No issues with index controllers.

Not sure what you can try mate. I assume you’ve done all the usual… drivers, re-pairing, change usb ports, unplug all other peripherals etc. my hotas used to cause the type of issues you describe.

I’ve noticed the same problem. With PP off and SS 1.25 the controller (index or wands) went crazy. as soon as SS in the pitool was set to 1 again everything works fine.
Maybe it would fixed in a patch

Hi @MagiJedi Can you tell me your equipment configuration and operation steps? I will feedback the bug to the test engineer and ask them to help reproduce it. Thank you.


Steam vr beta. Latest pitools. 9900k@5ghz + 2080ti @ 2175 + 32gb ram@3000. Windows 10 on latest update.

I’ve already reinstalled steam vr & knuckles driver through steam, and reinstalled pitools.

Pitools setting:
PP on or off (happens either way) I prefer off
Pitools super sampling (forgot what it’s called) on any value lower than 1
Hidden area mask on or off (happens either way) I prefer on
Motion smoothing and FFR off

Steam vr settings:
Mostly default, but please note if I drop either global or game specific super sampling below 100, I also get the bug

I typically open steam, then turn on the headset followed by pitools, then steam vr, them finally the controllers. Changing the order of the above doesn’t seem to matter.

Open nms. Load game - New or existing doesn’t matter, neither does difficulty.

When in game, pull right trigger and watch the controller rapidly appear and disappear.

Again, I want to stress that the thing that makes this happen is to subsample, either dropping pitools quality lower than 1, or dropping steamvr supersampling lower than 100.

Edit: forgot to mention in game settings are all at lowest, including resolution. But I’ve tested changing all the graphics and video settings and none mattered.

Thank you Matthew.

Try it without the PiTool Parallel Projection turned OFF. IIRC, I read that someone was having controller issues and that fixed it.

I did. Only works with default super sampling.

That’s strange. At least it sounds like you have a temporary solution. The NMS update seems to have some problems (which aren’t just limited to VR). Hopefully, the issues will be fixed soon.


I finally found a workaround that might help you guys with your investigation and others such as @GerVR who are experiencing the same issue.

I typically play without the SteamVR Mirror window up. While troubleshooting further today, I got tired of putting my headset on and off and turned on the mirror instead.

Turns out, having the mirror window showing fixes the issue, but (at least in my case), IT MUST REMAIN IN FOCUS. If focus shifts to the actual No Man’s Sky window, the issue starts happening again.


I appreciate your feedback and I will inform the team. Thank you

1 Like

my issue with NMS mirror is that unless I set pitoool quality to .5 it doesn’t fit my main screen and I can’t select anything in the menus because the mirror window is way off to the left/top

does any body know how to resize or get rid of that NMS VR mirror or make it sit at the screen center without going below 100% VR resolution to match my monitor resolution in order for it to fit?

Maybe this will help:

1 Like

Hi guys, I found a trick to refocus the window of no man sky.
You just need to download Sizer 4.0 (I put you the link below)
Once you have it installed, you just have to launch No man’s sky and ctrl + windows + z to open a window that offers different resolutions to resize.
I tried and I do not feel like winning performances but I let you test;)
I hope it will be useful.

Link for download :
Screenshot :