Bricked 8kx after firmware upgrade

Pitool told me there was a new firmware for the 8kx, i tried flashing it and an error came in the end.
The HMD then was stuck in DFU mode. But i eventually managed to flash it using DfuSeCommand.exe through cmd.
The problem is that once it finished flashing the firmware, the HMD shows a blinking yellow/green light (i can’t quite tell the exact color, it seems to change depending from the position you look at it, but it’s always the same color).
So, now i’m stuck with the HMD not being recognised in Pitool and with this blinking light (that is not the DFU blinking rgb lights).
In Pitool it says “Diagnose10600” which is HDMI/DP disconnected. But of course it isn’t.
Don’t know what else to do. Could my 8kx be bricked with no way to resolve the issue?

You can try reflashing. However best to file a ticket and support can use a Teamviewer session to fix this.

I had something similar happen to me the last weekend.

Updated the pitool, got that new firmware info and tried to flash it. Got a message with failed update and to contact pimax service

Had a lot of trouble initially becasue the dfuupdater wouldnt work.
I found information about a guillemont driver on the computer creating problems.

I followed this giude;
That didnt do it completely, the new firmware did not load anyway.
When I looked in the device manager it said I had a DFU in FS mode.
Uninstalled that unit including the drivers.

Now I could use the DFUupgrade via command prompt and the process seemed to work but 8KX was still missing in pitool afterwards.

So I downloaded the latest 8KX driver here on openmr and replaced the p2.dfu file with the new one, changing the name to p2.dfu

Suddently the 8KX came online in pitool and started to work again.

I dont know if all steps was nessesary or which step was the real key to success, hence the long despription of the fix.


Hi! Did you find a solution? I have the same issue where USB works but DP connection is not picked up.

1 Like

Opened a ticket and they sent me a recovery file to flash.

1 Like


You may first try to tips provided from the community.
If it doesn’t resolve the issue, we suggest you to log a ticket at our helpdesk.
Our technician is ready to provide assistance to you.


1 Like

I have exactly same problem now. So i am waiting for them to help out with the ticket. The headset worked fine before firmware update however i would always get a black screen on my right eye in upscale mode. That started to happen after their pitool update.

One technique is to install pitool on another PC (doesn’t have to be powerful) then connect the headset to that and let it pull it out of DFU. Then connect back to your normal pc and test.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.