Beat Saber crashing 5k XR

My Pimax 5k XR really struggles with this game, I have had a look through the other topics but can’t seem to see anyone referring to the exact same issue, nor can I see a full overview of exactly what settings should be applied.

Upon launching Beat Saber, the headset slows to a crawl of approx 0.3 FPS on the initial disclaimer page. It’s incredibly painful, and if I’m lucky after at least half a minute I can line up a controller to hit ‘Continue’. At that point the menu may also stutter, but if I’m lucky another half a minute later the game can ‘find itself’ and I’m back up to full frames (82 for the XR). However when I choose a song and hit start, the first few seconds of the level will also stutter completely, and then usually fix itself after about 5 seconds (then the entire song plays fine), but this is often long enough to fail the level.

I used to have bloom issues and duplication issues, they have been sorted out, but this still renders the game mostly unplayable. Even worse, it often ‘crashes’ the headset completely when it stutters, at which point the only way to recover is to restart pitool service.

Strangely when the headset is only showing a frame every few seconds, the desktop mirror is running At full FPS just fine.

I’m on latest pitool, latest SteamVR.
specs are more than sufficient (8700k + 2080 Ti). I have tested FFR, smart smoothing, ‘vive only’ and parallel projections all on/off, and tested Large & Normal FOV. If somebody could outline which of these is ‘supposed’ to be on/off that would also be useful. I have both index controllers and vive wands, and an OG vive, this issue is only present when the Pimax is involved.

So frustrating as when it isn’t stuttering it is flawless.

Any help hugely appreciated?!

1 Like

@brian91292 might have ideas as he had a lighting mod.

I had the same issue that it sounds like you are having, my problem seemed like it was solved after updating to the latest pitool beta, V1.0.1.144. I switched between steamVR beta and no beta. I cant pin point what fixed it exactly, but I’d start with reinstalling the latest pitool beta and steamVR opt out of beta option. Oh, and the latest Nvidia driver too.

Also I meant to add i7 - 3770k, 2080 ti, vive 1.0 base station, index controllers, no issues. So your system can definitely handle it.

1 Like

Do you mean Ryzen 3700x Or 8700k? & which headaet did you receive?

i7- 3770k my bad, my mobo is like 10 years old. Pimax 5k+


Not bad but yeah the i7 3770k will hold the 2080ti back a bit in comparison. I have a i7 4790 but need to find a cheap cpu so I can flash hopefully a z97 gaming5 msi itx board to support it.

I have a bunch of computer parts. Hobby builder. Lol

1 Like

Yea, I need to upgrade, I just haven’t wanted to dish out the money for it, mainly because I haven’t felt the need for it quite yet. Besides I don’t know any better when it comes to my 2080 ti being held back so I guess I’m in that ignorance is bliss state. Although my friend who is a hobby builder like yourself has an i-9 and an complete index setup and wants to try my 2080 ti in his rig (he only has a 980 ti) to see if he can reach the 144 Hz on the index. I’m curious about it myself too, but I also know that I can’t unsee it.

1 Like

Truth a lot depends on games your aiming to play. I know prior to my cpu upgrade (i5 6500 - r7 2700x) my 1080 ti had a lot of aliasing.

However my i5 6500 seems to pair well with my old r390 8gig amd card.

Pitool on that end has improved considerably. During m1 testing a 980ti failed hard. But since Product release 8k has been proven to be able to run quite well (within reason) on r9 390, 980ti & even 1060 6g in titles like skyrim & more.

While admittedly they need to work on releases (ie what stable means) generally speaking the improvements are good just seems at times hastely released.

I’ll try switching SteamVR beta, I’ve been on pitool 144 since the day it came out and have reinstalled also.

i use the htc vive pro set the same resolution as about 3200*2800,the same phenomenon happend, it seem that not a reason fof pimax

1 Like

Did you have any luck with the steam VR beta? What your nvidia drivers?

Haven’t been able to test yet, will be this weekend

the advice for switching to beta AND back is usually about getting steam vr reinstalled that way, the beta is not recommended or tested with pitools

does anything else work, like steam vr home environment?
maybe you have some mods in beat saber that are the problem
you can try uninstalling and installing beat saber in steam to get rid of anything old
BS needs parallel projection on, anything else like ffr, smart smoothing or vive compatibility off (that’s what i use and a rtx 2080ti should be able to handle BS easily)

1 Like