Backer 204 initial impressions 5K+

Initial Impressions:

Packaging - Good, no damage to box, everything present, only thing ‘funny’ was the power adapter was in the headstrap box and vice versa.

A few opening pics and software setup

Installation and Setup:

It was a mess. Initial install of the PI Tool software seemed ok, however after attempting to start it I was immediately greeted with an application crash. No real debug info to use for trouble-shooting so I tried the usual things: Rebooted machine. Uninstalled and reinstalled PI Tool (ver. 90). Uninstalled ver. 90 and installed ver. 84. Restarted multiple times, adding removing the headset cables many times.

Throughout these trouble shooting steps the headset was on and displaying the default PI Tool ‘space’ environment. Inside out tracking worked as well (though just rotational).

Finally, after a good 1.5 hours I stumbled across a blurb someone wrote about removing a file from the install directory. Gave it a try and it stopped crashing. Instructions to remedy:

  • Remove or rename this file (like ssleay32.dllbak):
    Program Files\Pimax\Runtime\ssleay32.dll

Once PI Tools launched, it was NOT smooth sailing. Headset tracking wasn’t working, the base stations didn’t show up and I paired the controllers again, but after multiple reboots one of the controllers stopped showing up, but attempting to repare it was greeted with a ‘no dongles left error’. Another hour or so of fiddling around, rebooting, powering on and off etc. Before a reboot finally got everything working. Instructions (best I can surmise) to remedy: Lighthouse config data gets ‘corrupted’, I deleted this multiple times before a reboot finally worked, I don’t remember the exact path since I am now at work, but it was similar to this

  • (fixed this path to the correct location)

    Users\User [Name]\AppData\Local\Pimax\runtime\config\lighthouse.

  1. Shut down PI Tools 2) Unplug power from your lighthouses & headset 3) Delete the files in that config directory 4) Shut your computer down 5) Restart your computer 6) Keep your fingers crossed that on logging into Windows the PI Tools room setup appears

One more thought - don’t launch ‘Steam VR’ until you have everything registered and tracking in PI Tools.

Now that the headset was running, it was pretty late so I didn’t have much time left to play with it.

Headset Impressions:

  1. Fit and Finish: Seems good, as many others stated, it is impressively light weight. It seems put together well, no visual defects. I plan to baby it since the plastic housing doesn’t seem nearly as robust/durable as the Vive/Vive Pro, that’s a trade-off to achieve the low weight I think.

  2. Lenses: Yep, they are huge. Yes, very large sweet spot. No noticeable circular banding like the Vive lenses, very clear.

  3. SDE: Still there, initial impressions are it is exactly the same as the Vive Pro (which is ‘ok’ to me, not quite what I hoped when I backed the 8k a year + ago, but definitely serviceable)

  4. Resolution: Not as clear/high resolution as I was hoping. Again, very similar to Vive Pro, but I need to spend a lot more time tweaking PI Tool settings before I can make a true comparison.

  5. FOV: So funny, my first impression was, “This is it?”. Not the same ‘WOW’ factor I was anticipating.

  6. Audio: 9mm Plug is finicky, my headset kept popping out one of the channels because the plug would move a bit. I think this will end up being a long term problem, I might have to switch to a wireless headset.

  7. Comfort: Good, even with the default strap. Going back to external audio headset is a pain, but the HMD itself is so light-weight it is very comfortable.

  8. FOV settings/edge distortion: Too early to give a proper assessment here but I moved the FOV to large and spent an hour or 2 in Fallout 4. The side distortion didn’t bother me, could be because I was having some binocular overlap issues, but by this time I was done trouble-shooting and simply wanted to play something before bedtime.

  9. LCD brightness/colors: Acceptable. I thought about this, but honestly it didn’t register to me as an issue. Sure, it probably isn’t as good as OLED, but it is very usable.

  10. Black colors: Ok, sure, not true blacks, but it is definitely usable. Have not tried it in a game like Elite Dangerous yet though.

  11. IPD Dial/Adjustment: Seemed to work well enough, registered the changes in the headset and it was definitely changing the IPD. I didn’t get it quite dialed in completely, but will spend more time tonight tweaking to perfection.

  12. Performance: I have a 8700K running at stock, 32 GBs 3600 memory, 2080TI, Samsung 970 MM2 ssd. Initial impressions are that it ran smooth - 90 fps on FO4 with large FOV. Need a lot more time to truly assess.

  13. Tracking: Still seems a bit ‘wonky’ kept losing tracking (screen going grey) when readjusting the headset with my hands or moving out of the center of the tracking circle.

Last words:

Setup was extremely painful, fortunately I think most of us early adapters are probably pretty PC savy and used to trouble-shooting hardware/software issues, otherwise getting your headset running would be an insurmountable task for your average consumer. These issues need to be resolved before they ship to Pre-order customers.

The headset itself is solid. My first impression is this is like a Vive Pro (resolution and SDE) with a much larger FOV, better lenses and large sweet spot. Although my first impression with the FOV wasn’t ‘knock me off my feet’ there is no doubt in my mind going back to the regular gen1 headsets with 115 degree FOV would feel extremely limiting. I will sell my little-used Vive Pro in the next few days for $500 and be happy to move to the Pimax for full-time use.

Additional observations

I did notice a bit of the black ‘dot’ pixel pattern some others rereported with the 5k+ screens in the demo environment. It isn’t extremely noticeable, but I recall thinking, “Ahh, that’s what those other people were talking about.” Probably only visible with certain colors and only when the entire screen has one color.

Dead Pixels - did not notice any


really nice feedback, quite detailed and appreciated as I am a 5K+ convert as well and hopefuly they will have worked out some of the software/hardware install bugs by the time I end up receiving mine which is looking like next March at this rate.

1 Like

Theres a new version of software available I believe. PiTools Version

1 Like