[avoided] Steam VR dont work correctly since last Update pls help

Yesterday i want to play again with my Pimax, i had 3 month old drivers from Pimax and everything worked well. At the end i saw a auto update massage and installed it to the actual version and now when i start SteamVR i just see the Pimax logo and no vr room or something like that. Can i get the old software or does someone know how i can solve this? Please help i want to play xD

My Setup:
i7 2600 3.4 GHz
Ram 24 GB
Nvidia GeForce 1060 6GB
Win 10 64 bit

Are you running a laptop by chance?

1 Like

no i dont use a laptop.

After installing PIPLAY, it found a low graphic card like my R9 290, i must go to piplay s settings and clic on a button “complete version” to enable PIMAX MODE.
Maybe you re in the same case.

1 Like

cant see any button like this in piplay options

maybe it could help

What version of Piplay are you using & what was previous version?

@jonnypanic i believe has a 1060 as well.

Also use @PIMAX-Support to help support find your request.

1.2.97 at the moment and previous i dont know i dont used it since months

if i restart my pc i can start Piplay and steam vr normal but it should show this gray net in my pimax but it keeb showing me this logo if i try to start a game :

oh its german xD (308 says VR headset has no signal)

1 Like

i suspect that when you clicked update, you forgot to turn off the antivirus prior to the update? do you remember disabling the anti virus before you clicked on UPDATE?


Update i luckily found the old piplay setup :D! it was 1.2.57
-uninstall new
-install old

Works fine again ^^ and im happy

I have Bitdefender i cant turn off ^^
but thx

I would reccommend trying to reinstall 1.2.9x (x being 3 5 or 7)

There has been significant performance/quality improvements.

Ensure to use taskmanager to kill all instances of pi server & piplay.

Uninstall piplay & install new version.

With Antivirus is reccommended to disable but if you successfully installed 1.2.57. You should be good

1 Like


This is more of a FYI for you

You can disable bit defender temp. to do this you have to start your PC in “SAFE” mode first and once you are already there, you have to open msconfig.exe. Select the “Services” tab and there, and only then, you will have the possibility to UN-tick the BitDefender services. Re start again in the normal way (not safe) and BD will be “turned OFF” When you want to “turn ON” BD again, simply reverse the procedure.

The problem is that you are not able to stop BD services because of the “auto” protection feature IF you are on the NORMAL state (not safe) of Windows OS.

1 Like

When it happens to me, I just stop steam vr then unplug and plug USB, right clic on piplay icon to clic on PIMAX mode. After that I check if the headset show PIMAX s logo and it s ok.
I hope it will help you.

Thank you all for your fast help. Very nice Community :slight_smile:


Thanks guys.

@Grix Could we use Teamviewer together when you’re available? I would like to assist you for letting Pimax 4K to work with Piplay 1.2.97 that has many improvements actually.

1 Like

Sure that would be nice how can i contact you when im avaiable tomorrow?

You may send ID & Password of Teamviewer to support@pimaxvr.com when you’re available.