Audio not working, then completely BROKE after an update

Look im sorry for using all caps in the title but its how desperate i am.

Tonight i fired off my Pimax artisan for my usual daily VR activities, only to realise audio wasnt working. So after fiddling around with different headphones, replugging the headset, using 3 different cables (yes i have 3 because ive had the headset for 2 years), to no avail.

So as a last ditch effort, i updated the headset and pitool (keep in mind i hadnt done so since i basically got the headset because i never had issues before now.

After the update, the screens are now all wrong, makes my brain hurt and have a red shift in color, not to mention the audio still doesn’t work!!!

Look, ive been using the headset for 2 years as mentioned previously, I know how to work around its quirks and issues. But at this point im out of ideas, and if it can’t be fixed, then i will be very ashamed to have recommended to headset to many people. Offer me ideas, ask me questions!

Edit: After more testing, it seems turning on the headset causes all my normal desktop screens to suffer from VERY HEAVY ghosting aswell…

  1. open a ticket on pimax site; they will contact you really fast for such a big problem. Even after 2 years, they will try to help you with pc/pitool settings and defining what is your problem.
  2. your data might be corrupt on disk. For this issue the best is to wipe windows, and install all again. It is painful, I know.
    2a) Other solution is to uninstall pimax and steam vr, and erase all folders and traces of them, then reinstall.
  3. if possible, try your unit on other pc; if works, then go to 2).

That’s weird your desktop screens ghost?

What Firmware version flashed on your Artisan? It is possible if you let it auto update it may have flashed an incorrect firmware.

As Joe mentioned filing a ticket is a good idea as a Tech can schedule a remote session if needed and potentially fix it.

Support link below.

PimaxVR Support

Main Site
  • Self Help Database
  • Submit a Ticket
PimaxVR Forum Support

This group consists of PimaxVR Staff Specialists for assisting PimaxVR Consumers with resolving Ticket.

Please follow this Procedure before Requesting help.

  1. File a Support :tickets: At
  • PimaxVR
    You should receive a response within x Business days.
  1. If you have not received a response after x Business days or Support personnel is having difficulty understanding your request. Please Direct Message(PM) PISupport requesting assistance.
  • Please provide the following Information:
    Support Ticket # & Details of issue.

if your support issue is Tech related please explore:

  1. Use Docs in Left menu to explore 2 & 3.
  2. Pi-Guides & Troubleshooting. (#guides )
  3. Community Support - review Solved and post question if needed. (#vrcentral:helpme )


First, I would recommend you to have a full Pitool and SteamVR uninstall. Try to delete all related PiService files and others.

Reinstall these 2 softwares on your PC, connect the headset.
If there is any FW update, please proceed with it.

I have spoke with our technician, the ghosting might caused by the setting configuration.
After you have tried the method above, yet it still appear.

Please kindly contact with our tech specialist, they will check your system setup and schedule a remote session to do the troubleshooting.

[Bug-or-not my 8kx is dead - PimaxVR Software / PE Bug Reporting - OpenMR | Community](

1 Like

same after an update with my 8kx and pimax doesn’t want to assume this problem

i’m really outraged

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.