Asobo Fully Fixed MSFS on Large FOV in Sim Update 12 Beta?

Small and normal FOVs work well on Pimax, but the Large FOV has a weird glitch that occurs intermittently.
I wondered if some other Pimaxians + Simmers could help up-vote this ticketed thread in the MSFS community.

Thanks for your support!

1 Like

I will post a copy of your post in OpenMR to help visibility.

I would also recommend using the share option on your topic to share on r/pimax. This would help with visibility for this topic and help promote OpenMR.


1 Like

I think I shared it correctly…the cross-posting thing is new to me.

1 Like

Well there are 2 ways to do the same thing.

One being the topic share or using the copy link from the post itself. The share option just gives a direct to Reddit option without requiring to copy the link.

1 Like

This has been resolved in Sim Update 12 Beta!
Way to go ASOBO!


Thanks for your support in getting this fixed! They did it!


Yeah super

Aplushhss :innocent::+1:t2::+1:t2:

1 Like

Well after I said all that I now find that there’s instead a apparent glitch with frame timing that is actually more frequent than the previous problem. Notable every time I rotate the HMD…more testing needed. Once again Ill enlist the help of the openMR community to test this issue and vote it up if you can : Large FOV causes glitched frames as rotation in VR occurs - Virtual Reality - Microsoft Flight Simulator Forums
If you see it it will appear as “jitter” when you rotate the hmd. As if a frame was held up and displayed with incorrect rotation, so its only noticable as the hmd is rotated. It doesnt appear to be missed frames or stutter, but as misplaced frames…

WFOV operation confirmed. Once again PIMAX is able to advertise the WFOV HMD.

Various fixes were introduced, but after playing with it for a while I noticed that new problems were added. Cloud paths and distant culling seem to be getting worse.

When flying at high altitude in Darkstar, anything outside of about 80nm is drawn as sea level even if it is land. even maps on MFD are culling at such ranges… It’s a nightmare.

And yes when I turn my head the outside frame is in view with a drawing delay. Something is strange. I will be patient.


Can you copy your findings to the forum issue linked above?

1 Like

I have not yet been able to determine if the problem of the outer black mask entering the field of view due to drawing delays is due to a bug or simply a performance issue.
I think the settings need to be adjusted before reporting to the forum, as a slight reduction in the drawing resolution improves the delay slightly.

1 Like

Actually I played today after a reboot of my system and I could not reproduce the issue! For the first time ever I’m playing Large FOV locked 45 FPS. Long time coming!

Also FYI I’m finding hags on is no longer a problem if I use steamVR. I have not tested with PimaxXR yet.


I will try darkstar tomorrow, but for whatever reason my op concern was gone today! Finally large fov is working perfectly!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.