Artisan doesn't boot on 72Hz mode

Hi there !

I’ve already raised some tickets to Pimax support but it didn’t help unfortunately.

So if anyone knows how to fix this…

My Artisan is working perfectly well in 120Hz and 90Hz mode.

But! I can’t use 72Hz mode (and as a simracer there is some conditions I’d be happy to use it).

Headset keep trying to boot but the LED never become green.

I tried several combination of firmware and PiTool versions already

1 Like

Hello,
Can you please provide the ticket # to me, I will take a look at this case with the supervisor. Sorry for the inconvenience sir.
Regards.

2 Likes

If the headset works perfectly in 120Hz and 90Hz mode, but not on the 72Hz.
It ought to be a firmware glitches.

You’ve tried which firmware version so far?

2 Likes

There was two tickets actually : #19743 & #21538.

I can even forward you the email conversation we had, there is some .zip files with some firmware logs I made upon request.

Apparently I didn’t help identify the issue at the time but I thought maybe now there could be some news…

1 Like

And I tried 271 debug, 272 debug and 273 firmwares mainly.

2 Likes

At some point some told me it is cable issue but considering 120Hz & 90Hz are working properly I have a doubt, I wouldn’t like spend money into a new cable if I’m not sure this will solve the issue you know :slightly_smiling_face:

2 Likes