Anyone else having problems with Derail Valley after updating to latest Pitool?

I tried playing Derail Valley again since updating to the latest Pitool and now my in-game position is too high and it will no longer let me teleport to the correct position inside the train cab. I also can’t use the inventory menu screen anymore. Everything I pick up from the inventory just falls to the ground and I can’t select the settings option at all.

I’m not sure if the issues are coming because of the Pitool update or because of the recent Derail Valley update. Anyone else playing this game?

1 Like

I have the same problem since the pitool update, I can’t interact with my inventory or cockpit controls anymore.
On the other hand, I do not have a teleport or position problem.

1 Like

I have intermittent issues with the vive wands not showing up in the game, I can teleport but cant move left or right, and cant access anything in the menu. I have to restart the game to get everything to work sometimes. Im on version .91.

Have either of you noticed that the game stutters when cruising a locomotive down the track. The Derail Valley logo will show up for a split second when this stuttering occurs. I dont have this stuttering with any other game…

1 Like

Yes, I experienced the stuttering to every since I first got the game upon its release. It’s not even playable for me right now since the recent Pitool update though. Really strange symptoms and not sure what could have changed to create all these problems

It stutters in my 8K and 5K+. I tried turning down ALL “in game” quality settings and still get the stutter. I dont play it much but I just got the Steam engine fired up. Its pretty cool but not sure how feasable to do hauls

@Doman.Chen, @PimaxUSA I noticed in your changelog for the latest Pitool that you made some changes to the controller functions to fix some apparent issues with other games. I wonder if your changes did something to break how the controllers worked in Derail Valley. Can you look into this?

1 Like

@Doman.Chen, @PimaxUSA This may be a game Devs issue but I wanted to point this out as others have had the same problem with this game. [quote=“stixvr, post:5, topic:16273”]
Derail Valley stutters in my 8K and 5K+. I tried turning down ALL “in game” quality settings and still get the stutter

Thanks for checking in to this guys!

you can ask the DEVs in Discord, maybe can help: Altfuture

1 Like

Cool thanks, How do I post in the thread? Its telling me that I dont have permission to send messages in this channel. I can post in the gameplay, I guess only Devs can post? So I need to post the issue in the gameplay thread probably

in discord you have some text channels… and one of this discord channels (on derail valley server) is #bug-reports:

open this image (the preview is to small)

O ok gotcha, Thanks!

Ok Derail valley players I sent this message to the bug issues at Discord.

Message for devs. With the Pimax 8K and 5K+ the game stutters (game freezes for half second) when running an engine down a rail, or when I move around quickly, FPS drop for a split second and I notice that my GPU is taxed just for a split second, and when this happens the Derail Valley logo shows up for a split second, I have good fps otherwise. I have tried lowering all in game settings and keeping my super sampling to a minimum. Also at the Pimax forums others with these HMD’s are having same issue. Hopefully this can be fixed. Thank you!

I already got two replys and apparently its common on all headsets. I asked if there was going to be a patch,they said devs are aware and working on it…

1 Like

What version of Pitool are people using that actually allows you to play this game? Like others in the post I can’t interact with anything in the game so I can’t even start it :frowning:

I am currently running the Beta.


Anything above V1.0.1.103 and my controllers do not work in game.

1 Like

Im still on .95 and my controllers dont work, they used to be hit and miss but I could always restart game to get them to work, now they dont even show up in game and restarting app doesnt fix.

Also that stupid bug that the devs were supposed to be fixing is still there the last time I had the game up and running, the bug was where you get stutter in the game when running down the rails or moving around the shipyard quickly. I cant play it at this time due to no controller function :(_