Another 10600 out of the box for an 8K unit

System is a Ryzen 2700x on a Crosshair VII board, running 32gb of Platinum Corsair RAM, and a AORUS 1080ti 11GB Extreme. Right out of the box I am getting the 10600 error. I have tried everything mentioned on the form so far: re-flashing firmware, updating all PC drivers, updating graphics drivers, uninstall and reinstall of PiTool, tried every DPi port with/without other displays plugged in, etc. @Doman.Chen @Pimax-Support

1 Like

Hi Randy. I have a similar setup save mine is an itx b450 Asus Aura gaming board with 16g ddr4 corsair dominator.

What does it show on Diagnose page (found in Help Pitool tab).

With Updating Drivers. Is your MB chipset & drivers & bios from MB site?

Are you running Pitool 121B?

Your 1080ti should be good but check on Nvidia site for firmware update for DP1.4 features as well.

At this point I have one less error after reinstalling the Nvidia software/drivers. PiTool is only showing “Plugin HDMI/DP” whereas before it was showing a second issue, something like the USB. All motherboard drivers and BIOS updates have been done from the manufacturer website.

The 8K unit has flashed a “screen” of sorts at times when restarting it or rebooting, but never held a screen. The light on the unit is red.

1 Like

If your using the latest nvidia software which Pitool version are you running?

With tge headset check where the cord plugs into the headset. Press it in as it may have come loose. The cable can be unplugged & replugged but is tight.

Do you have another pc available to test connectivity?

Using the latest version of PiTool, and the cord is firmly plugged in. I don’t have another computer laying around.

1 Like

109 shoukd be good but there are a couple new versions. In the Banner topic there is a link pitool downloads. Try the latest Beta 121.

1 Like

Have you tried with the headset power on, reboot your pc? This usually solves the cant find hmd problem for me.

1 Like

@Heliosurge broken link for the beta 121.

@oysta1109 I appreciate the try, but rebooting was one of the first things I did.

1 Like

Hi Randy ga e it a try. It was slow but gave option to download.

Alternatively try the link in this post.

1 Like

The 121 beta seems to have done the trick for the moment. Thanks @Heliosurge !

Not super thrilled with the resolution…doesn’t look like two 4k screens. Still way more screen door effect than there should be. Doing some testing this week to see what the deal is.


Awesome Randy good to hear. As we have similar sysyems we can compare notes.

A free demo WarRobotsVR looks pretty good.