Alyx and Skyrim won't run on my Crystal

I have received my Crystal. The clarity is stunning. I mainly fly Microsoft Flight Simulator, and it’s now a whole new experience. But Alyx won’t start, giving a message on my computer screen: “Timed out waiting for response from Mongoose. SteamVR needs to be restarted.” I asked for help on Reddit. Someone suggested adding running parameters to Alyx. I tried “-novid -console -vconsole +vr_msaa 2” with no success. Simply adding “-novid” brought me into the game menu. I can even load a saved location and play from there, but starting a new game would still crash.

Skyrim simply won’t start, without any error message.

Any Pimax users encountered this? Help is greatly appreciated.

1 Like

PimaxXR/OpenXR disabled?!
Alyx wants OpenVR


Try witb lower resolution. I have similar problems om other headsets with this game when the resolution is too high

1 Like

Thanks for the suggestion. How do I enable openvr/pimaxvr?


Thank you for the advice! I have lowered the resolution in steamvr, and lowered the setting in alyx, and still no luck. Any other way to lower the resolution?

1 Like


Adding -novid should be a fix for the Half-Life Alyx.

Have you tried verifying the files for both Half-Life Alyx and SteamVR? It’s possible that some files are missing and may need to be reinstalled.

  1. Open your Game Library on Steam

  2. Right-click on your game

  3. Select Properties from the menu

  4. In the Properties menu, select ‘Local Files’ from the left-hand panel

  5. On the Local Files page, select ‘Verify integrity of game files’

  6. Steam will then verify your files. Please note this can take a few minutes!


Same question on Alyx, adding “-novid” works for me; Maybe you can also try to update your steamVR
And Skyrim run well on my Crystal

1 Like

Thank you for the advice. I have figured out the reason for the crash. It’s because I turned on the CPU auto turbo mode. I turned it off and everything is fine. But my 13900K is only running at 3.0ghz, and I will explore a higher frequency without crashing.

1 Like

The BCLK is might be getting increased with the turbo setting.

I suggest manually force BCLK to 100Mhz or even slightly lower then re-enable turbo freq. That might solve your issue.

1 Like

That’s exactly what I am experimenting. Thanks!


An overagressive BCLK automatically set by the bios can have all sorts of spurious effects so I think you are on the right track. Issue could also be memory timings, you could also set those to default as a test.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.