ALXX mod Return To Rapture Chapter Two issue

Just started playing this and discovered a problem with Pimax hmd and Index controllers.

You can’t activate the mods plasmid menu or activate a grenade. In an exchange with the mod’s author it appears the grenade button (left hand B button and grip squeeze combination) won’t activate the plasmid menu. as well that grenade button won’t activate a grenade. This appears to be a difference in how the Index controllers work with a Pimax vs Index hmd in this mods implementation.

You can get by this and play without plasmids. You need to shoot the targets in the plasmid tutorial in the first level to activate the exit using tutorial exit button on the wall as well as activate the next door.

If you pick up a special weapon you can’t drop it as you need the grenade activate button to do so.

You can grab and throw back an active grenade thrown at you.

You can carry a grenade and throw it near an enemy and shoot it and it will explode, but you can’t store it in your wrist pockets.

That’s all I know so far.

Oh and you can’t play this with Sword as they don’t have a B button

The buttons are mapped correctly on SteamVR?


Yes. I have no issues playing ALYX, any other mod (have played most 4 and 5 star maps created for the game) and no issues wit RTR Chapter 1 which i played through several times.

Have you played Chapter 2 with Index controllers?

@hammerhead_gal @PimaxQuorra @SweViver @VoodooDE @mixedrealityTV

Any of you folks tried this chapter on Index controllers?

I played all chapters in Rapture.
Yes, there was something fishy with green grenades from plants (that type which you need to squeeze and throw).
I let it go by taking it with right hand, and then selecting another weapon (regular gun).

After finishing Alyx, I was not ready for such a short game (under 20hrs, do not remmember exactly). But thanks to different mods, I played it a lot.
Usually I browse the most downloaded mods, and try them. This Return to Rapture is excellent, but some others are also cool.

No. But I don’t get the sense why the HMD, which only transmits the BT signal to SteamVR, should have any influence on it.

I don’t get it either but since everything else works I’m at a loss. Chapter 2 is a wip so maybe something will turn up. meanwhile have been able to advance despite using conventional weapons so far.

Are you talking about Rapture 2 that just released? 24 levels

O, no. I was wrong, I played just Wim Buytaert 1st version (8 levels)

1 Like

I found that chapter two, it is great mod - it really feels something else from just repeating Alyx world.

The combination for plasmid menu is left A and left trigger. I think it can be done with right hand also.

Beware, it was tricky to pass plasma guide.
I had to inject plasmid (after receiving it) into my body (belly), and with A button.
Then I burnt 1 dolly, and then another.
Then I took another plasmid and inject it. Burnt 3rd dolly. I saved third plasmid into my hand pocket.
Then I press button on wall, and that was it.
Later voice told me to go back and collect powers, but that is it.

I had to try several times, as often game do not recognize that I did my task.

1 Like

Solved it. Started a new game and it now works.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.