Adapter USB-C to DisplayPort compatible with the 8KX

Hello everybody,

I just bought the Lenovo Legion 5 Pro 16ACH6H Storm Gray Laptop, 16 " WQXGA 165Hz HDR, Ryzen 7 5800H, 16GB, 1TB SSD, GeForce RTX 3070 8GB.

I would like to know if anyone has ever used the 8kx with a laptop that has a USB-C 3.2 Gen 2 port (support data transfer and DisplayPort 1.4). I’m looking for a usb-c to displayport adapter that is compatible with 8kx.

You may need to do a keyword search on these forums for usb-c. I don’t think anyone has posted a working solution yet or has had a usb-c connect direct to a dedicated graphics card on a laptop…

1 Like

I will do some research.

1 Like

If you dont have anything by now, try this:ÅMÅŽÕÑ&dchild=1&keywords=usb-c+to+dp+1.4&qid=1623859195&sr=8-4

This is an adapter that supports the full DP 1.4 standard up to true 8K @ 60Hz, so it should be able to drive the Pimax’s half-8K at 120 (the headset currently does only 90 with the beta update and 75 without beta)


Thanks for your advice. This is the first adapter I bought but it didn’t work. The 8kx is detected in pitool but nothing appears on the screen of the helmet.

I then bought another adapter from the same brand which has DisplayPort 1.4 and Display Stream Compression (DSC) 1.2 standards:

With this adapter it works but the screen shows many dots like snow.

This week I will receive another adapter.
Once I have tested it I will come back to express my opinion.

1 Like

Oh wow thats super odd, looking at the shell I use that adapter to connect to my monitor (5120x1440 @240Hz) this actually requires more bandwidth than a Pimax 8K X at native 75Hz and even 90Hz and it works for that. Seems like the Pimax is picky then. Snow indicates poor signal strenght if I am not mistaken, so the power with which the signal is sent out.

Maybe try disabling energy savings just for that one USB port for the “working” adapter.


Maybe try disabling energy savings just for that one USB port for the “working” adapter.

Well I tried this method but it doesn’t work. I also tested the last adapter I received yesterday :

and this one fails to display the screen like the first one.

Among these 3 adapters only the one which has DSC 1.2 signal can display the screen but in my case there is a pixel snow problem …

Anyway thank you for your help and your suggestions.

1 Like

First of all I would like to thank the technical support who helped me find the solution.
Thanks to Doman chen and all the pimax team.

Now for anyone looking for a usb-c to displayport 1.4 adapter compatible with the 8KX (and other headsets) here is the one that works well for me:

As described above my new laptop was released recently. It has a USB-C 3.2 gen 2 port (support data transfer and DisplayPort 1.4 but not support thunderbolt 3).

Among all tested adapters only one of this brand has worked well for me.


Thanks for the research you’ve put into this, it will come in handy for others in your situation

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.