8kx works perfect, but is not detected in DFU mode

My 8kx works perfectly on Firmware 296. For hours and stable. Love it.

Now I want to try the beta 298 with 90 hz full on my rtx3090.

But the dfu tool cannot see the 8kx. Therefore I cannot flash it.

I tried different usb ports to no avail. Then I entered dfu mode manually, the led blinked as it should, still the dfu tool cannot see my headset.

Pitool connects within 2 seconds…

I cannot find a dfu device in device manager of windows. But I reinstalled the drivers from the pitool directory. Still nothing. I have no Guillemont folders or any note of it in the decive manager.

So I have no more good ideas, how to make my 8kx visible for the dfu tool.

Any ideas?

it does see it, it just doesn’t say so

did you try it with the new pitool 270?
seen this with my 5k+ lately but worked fine with the new dfu, did update my firmware on start without problems
when starting piservice launcher manually and then dfu.exe it did not show then hmd type and firmware but flashed it when selecting a frimware file and klicking download



Thanks for the hint. I already am on version 270.

Closing PiTool and starting piservice.launcher from task manager made a change. Now when I use DFU.exe and insert the firmware file (btw, is the 298 firmware really just 154kb?) and then press download, the screen of the 8kx gets white for the 10th of a second, then the headset reboots normally. But I still cannot play the new firmware in the headset.

More ideas anyone, please?

Read this thread and follow the advice given in the comments and see if that helps https://www.reddit.com/r/Pimax/comments/mdxmj1/pimax_artisan_doesnt_connect_after_an_update/


Thank you for the advice. I think, I made myself not clear, so sorry. At no time, the 8kx enters dfu mode, so the reboot after I try an update with the dfu tool, restarts the headset into normal operation mode.

But I found some new information, where the problem lies. As usual, when something does not work as intended, it is a driver problem. This is the case here. When I open my Windows device manager and then manually activate dfu mode on my headset (by pressing and holding the 3 buttons and so on), my heaset for aprox. 2 to 3 seconds shows the 3 color blinking from dfu mode. Then the led goes red, the headset freezes and stays there. The headset then ignores all buttons and cannot be connected anymore (error 10500). I have to plug it of or cut of power from the wall for my PC and replug it, Then it starts into normal mode again.

But the interesting thing is this: In the moment, when I enter manually the dfu mode, the Windows device manager shows me a new unknown usb device. That means, it does not see a new Pimax STFM device, it is missing the driver. When I then install the driver from the dfu driver folder, restart my PC and the enter dfu mode manually again, the Windows device manager shows me a Guillemont STFU device and of course, this does not work. By uninstalling this driver, it then shows an unkown usb device again (of course).

So my problem is, that I have no working DFU driver. The one delivered with the PiTool is recognized as a Guillemont driver. And I have no other driver. Had anyone this problem? How to solve this?

Any ideas anyone?

As a final note: nowhere on my system is anything, that has somthing to do with Guillemont. No folders, no data etc. I do not know, from where Windows gets this information.

1 Like

I’m replying just so that you know you aren’t being ignored.

I wish I had a suggestion. Unfortunately, I have no idea what’s wrong. The headset should stay in DFU mode with the 3 colors blinking, until the headset is flashed. It may be a hardware issue. Have you submitted a ticket with Pimax Support?

1 Like

Do you use any Thrustmaster stuff? I think their driver is called Guillemont


Yes, I have a trustmaster hotas for Microsoft Flight Simulator. But I have no Guillemont folders on my PC. I read somewhere, these folders should be deleted, but I cannot find them. And the hotas is not connected to my PC right now.

But thanks for the hint. This is a direction I will look into it more deeply. I will try to completely uninstall every thrustmaster parts from my system. Maybe this helps.

Ok, this is weird. I uninstalled my hotas drivers. Did not help. Then I uninstalled PiTool and all drivers, downloaded PiTool and installed. Now DFU.exe sees my headset but identifies it as Pimax P2 - 5k Format. And therefore lets me not install the software for the 8kx. It even sees the correct firmware installed and the serial number.

I think, this might be a case for the support now.

1 Like

Finally I got it to work, 298 is flashed and works. Tried starting the flashing process 5x in a row, then it started flashing and went through it. Afterwards I updated Pitool to 270 and all is well.

Still can`t find out, why this did only work with PiTool 258, why the dfu tools sees it as 5k Formal and why it only worked after pressing the download button 5 times in a row. Sometimes this headset is like a woman: it is stubborn and does not tell you why. Pressing the right buttons make things work then. :stuck_out_tongue:

1 Like

v258 is from 3/2020, i guess the hardware revision is unknown to that version (as 8kx was released later in 2020) and the tool just sees a greater revision as known and assumes its a 5k+
afair we used a STM driver package to install the DFU mode driver manually (you might search the forum for that, maybe you can try C:\Program Files\Pimax\Runtime\dfudriver\stm_dfu_3040_64.exe)

you forgot the part were it detonates

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.