8kx terrible performance in steam after pitool update? Steam VR won't open

I’ve had my 8kx running just fine for 2 weeks now, flying mostly X-Plane 11. To startup, I open steam and start Steam VR from the steam tab. I do not open PiTool, and this has worked fine since I got my 5k over a year ago, and now my 8kx.

Now after the latest PiTool update, and HMD firware update, steam VR will not detect the HMD if I open it from the Steam tab. If I open it from PiTool, I get terrible performance, tearing, and like 5fps. Unplayable.

If I open PiTool first, but open steam VR from Steam, it detects the HMD, but again performance is unacceptable. This was all working fine until this last update.

HMD Firm V2.1.255.294

1 Like

New pitool released? How was 2.086?

I went back to .260 and am still suffering very low frame rates. I’m doing some testing now, trying to get an apples to apples comparison. Since the update, the decrease in performance is drastic.

What is the native resolution of the 8kx in NORMAL fov?

Not sure what res is native at in normal fov should be around 87.5% of Large though.

Keep in mind Steamvr recently had an update that messed with gpu settings

Maybe it’s the official version of 2.086?

Pretty weird versioning but they did say that a new version would be out this week, right?


Possibly though @Alex.liu I think had said it was going to be 265. :laughing:

1 Like

Oh my… :nerd_face:

1 Like

Just checked and it seems to be with all it’s features judging by the changelog, right?

It’s not possible to copy/paste the text if You’re wondering why I did so many screenshots… :wink:

Oh and there’s still a few typos in the version text: “available:version_no”

I’ll give it a go and see if it includes PE or I’ll need to reinstall it as they (Kevin) mentioned it should include PE

EDIT: Didn’t contain PE (so it’s overwritten with the static image “Pimax Home”)… :slight_smile:


This isn’t the downloadable bundle version, that one is still coming and will include a few additional fixes (to pitool) that affect communication between the two.
266 = .086 Version 7.
You can run this version via installing PE .7 (but be aware PE can’t control the backlight brightness on an 8KX with this version).
Team might have inadvertently released this onto the upgrade server.


Looks promising though with 2.086 having 2 versions wonder if 266 is newer.

Good to see fixing Amd compatibility and more complete whats new.


Makes sense as everything seems to work exactly as with on first glance … :wink:

Thanks for the info! :wink:


Is there a direct link to .266 that we can download?

I want to do a clean install of Pitool, instead of an upgrade.
seems some issues carried over when upgrading from .264.

and wanted to do a clean install, so wanted the direct download link to re install .266 myself.



Not that has been posted. However in theory might be on the pimax main site. Though that hasn’ t been updated in awhile so maybe not.

1 Like

I just tried the two URLs (taken from https://eu.pimax.com/pages/support-center) I know but no dice:

EDIT: Different filename:

Either the filename is different or they’re not uploaded/made available yet… :slight_smile:

BTW: Haven’t seen this in (it was probably there but didn’t see it) but I looked for it seeing it in the changelog:

Just tried it in SkyrimVR:

A very welcome feature… :slight_smile:


Maybe check the logs. I recall someone used it to find ET software download.

1 Like

There You go:

Found it in:

11/27-21:33:24 Info: VersionItem::load mFileName, “http://pitool.oss-accelerate.aliyuncs.com/PiToolSetup_1.0.1.266_20201125.exe” “C:\Users\UserName\AppData\Local\PiTool\PiTool_266.exe” 0 2


Did you notice if it works? It’s ashowing DFR for me also. But my eye tracking is not on, there IRLeds are off and the FR is fixed on the very outside.


Yes, it worked, but it’s still a bit finicky.

When it doesn’t work I re-run the calibration (right click the blue/purple (?) aSeeVR tray icon) and restart the game/SteamVR)… :wink:


Calibration just doesn’t work anymore for me. The green dots appear and then they disappear immediately - no Calibration


Weird. I had that happening once too… :confused:

Try to change the distance to the lens (You probably need to get closer).