8kx stuck in update mode

Tried to update Pitools to the latest beta- and now I’m stuck in DFU update mode with the headset flashing green red blue like a lunatic christmas decoration.
Argh. It’s NOT the guillemot driver issue.
I tried everything I can think of:: Switching cables, Switching ports, cold booting the computer. Cold booting the computer after uninstalling pitools and then reinstalling. Cold booting and physically disabling power to the computer, installing a previous pitool.
Nada. Nothing, Rien.
The 8KX is stuck.
This is one of the big issues for Pimax I think- and it was my biggest recommendation in the ‘what will the next gen bring thread’; MAKE the headset easier to install, use and update. It’s a great product but very frustrating.
Any suggestions before I try to get Pimax support’s help in advance of the long Chinese holiday?

1 Like

Firstly, I need to verify that you’re using the manual flashing tool (DfuSeCommand.exe).

Assuming that’s the case, you might want to try performing the update using a different computer. Some people have had success that way.

If my assumption is wrong, try manually updating the firmware: PIMAX FOR DUMMIES #1: Getting Started with Pimax 8K & 5K+, Tweaks, Hints & Firmware Update Tutorial - YouTube


@neal Hi Neal,
I got the 8kx working again, part of the problem appears to have been inconsistent power to my external usb3 port box. However, weird things continued to happen- the started blinking the display, after another reboot the screens went to a horizontally striped RGB pattern. After yet another reboot of power to the HMD, I switched back to 75hz and all seems well again.
It’s strange that 90hz worked perfectly for me before this update! Oh well, they’ll sort it out, and at least it’s working well enough that I’ll be able to enjoy my DMAS headphones when they get here!



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.