8KX Help - Red, Green, Blue lights after firmware flash [Solved]

Please help, I tried updating my 8kX firmware and the Pimax light is now blinking red, green, and blue. I’ve tried to reinstall the firmware but the device is no longer found. I’ve tried holding the buttons down in the order to put it into dfu mode, but it’s still not recognized. I tried @SweViver instructions in a video for manually installing the firmware and it says the device isn’t connected. Nothing seems to work, please help. :weary:

open ticket & wait for remote session, it should work until usb FW uploaded is damaged on HMD which I doubt is the case, most probably you do something not right, you need to use command line if UI doesn’t work & try different nubmer 0 or 1 or 2 for me once it was 0 then 1, Sweviver video’s had all needed info how to use command like afair, so I can’t add new info here

1 Like

try to remove all power from HMD, wait 5 sec & check if DFU mode (RBG lightning) is still the case, maybe your HMD just didn’t restart after FW uploading


I tried unplugging it, once plugged back in it flashes blue, green, red again.

tried procedures described here?

1 Like

I thought that RGB blinking already means DFU mode. You do not see a DFU device anywhere?

1 Like

It’s flashing red, green, and blue but it says no device in the dfu.exe file, or Pitool. I’ve ended the services and tried the 8 second button press method.

1 Like

Could you check the USB devices in the Device Manager, if there is a STM DFU device?

1 Like

I checked, there isn’t one in the list. Unplugging and replugging the usb looks like it’s listed as Generic SuperSpeed USB Hub now.

The first pic is unplugged. The second is the Pimax plugged in.

1 Like

Ok, plugging into into my other computer it now shows STM Device in DFU Mode in device manager. I then ran this guy’s firmware flasher and I’m back in action and it’s good to go.


Anyways, thank you for the suggestions. :pray:


Why did you update any firmware? My 8KX is still like it came out of the box, and I haven’t seen any new FW yet. Where can I find it? ^^

I updated to this firmware as my 8KX was acting weird when I start my pc. I’d have to reboot it every time after I started Pitool.

Edit: corrected to 8KX firmware. I used this one.



That firmware is for the 8k+.

You want firmware 294 beta also in #Pimax-pitool:Pitool-Notes


Had the same problem trying to flash my 8KX. The firmware tool included with Pitool would not detect the headset and I could not update firmware.

At the bottom of the firmware links post is a cli firmware flasher tool, along with a video of how to use it.
I just uninstalled Pitool to make sure nothing was running and it flashed no prob.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.