8KX DCS bad jittering when turning my head at any speed

Aorus Z390 Ultra MB
64Gb RAM 3400
EVGA FTW3 Ultra 2080ti
Pimax 8KX

Got headset today and had very little setup other than getting the newest PiTool since I have been running my 5k Plus for two years. Steam home screen is perfectly smooth and Pimax PE as well. After loading DCS with the same settings as my 5K+ the main menu flutters a bit and when i get in any jet and move my head it jitters constantly. I have tried lowering settings in DCS, using native vs upscaling. PiTool on/off while steam vr is running. Steam VR says my lighthouses are up to date. I have both usb’s connected to red usb hubs. Anyone else seeing this behavior?

Its sounds like your GPU is struggling to keep up. What SteamVr settings are you running? The latest update pushed my per eye resolution to a x 3 supersample. Also with DCS i found running FOV on small ( 170 vs 200) made a huge difference on performance with out any real sacrifice in immersion

1 Like

Most likely, you were using a lot of supersampling with the 5k+, and some update to something somewhere made that unsustainable.

PiTool Render Quality always 1.25 (due to SteamVR blur filter). DCS World Pixel Density always 1.2 (never 1.6 due to this running through the single CPU thread). Now lower your SteamVR video resolution until things work. I suggest trying something like 2160v .

1 Like

Turn off Windows “game mode” and “hardware accelerated gpu planning” in game mode setttings. That fixed it for me.

BR Henry


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.