8kx Club 3d display port extender issue

So I bought the cable extender and 90hz it black screen flashes. It doesn’t flash on 75hz. My GPU is a 4090. Is there a setting I’m missing ? If not how bad is it if I run the 8kx in 75hz. Thanks for any input given.

1 Like

What are the headset firmware and PimaxPlay version?

1 Like

(post deleted by author)

Model 2075 I believe firmware 299 and the latest Pimax client i think it just updated to 1.14 if I’m correct

Do you have the debug firmware?

I believe I do, it was linked in another post I did months ago when I was stuck in dfu mode

90hz runs fine without the extender

This might related to the extender.

Oh yeah , was just wondering if playing at 75hz is really a big downgrade from 90hz.

I prefer to run stable 75Hz over not so stable 90Hz. It allows me to crank the picture quality up. Personally i do see some more flicker only at 60Hz, which i do use only if games are very performance hungry.
So 75Hz is in no way automaticly less good than 90Hz. It is more or less personal preferance.
Others prefer the more fluid 90Hz (turn on the spot/fast and you see the difference) with less graphical fidelity- Up to you.

@PimaxQuorra I wish lower Hz modes are in the pipeline for my Crystal. Please confirm. I would love to have a 60/72/75/80Hz option for optimizing quality settings per game. Right now playing Fallout 4 36xx pixels hor. with a 3090 @90Hz. Looks already great. But would love to increase resolution and/or ingame quality settings even more and use a 75Hz setting…


The 75hz suggestiion has been noted on our request list, and our engineering teams will be conducting an evaluation.

Would you be able to spend 5 minutes writing a review or sharing your initial impressions, and then posting it on other platforms? This could lead to exciting prizes such as a $20 Steam Gift Card, Pimax Accessories Vouchers, and more!

Agreed, but an unstable 90Hz refresh rate can significantly detract from the overall gameplay experience.

I need the extra length so I guess I’ll sacrifice the 90hz and play in 75hz with the cable extender

Seems like there isn’t any other choice.