8KX can't detect Lighthouse 2.0

Sorry but I’m quite new to posting on a forum. Tried to find a fitting topic but they didn’t seem specific enough. Also couldn’t find any tips in them that worked with my case. If I’m wrong, then I’m sorry for creating a new topic.

Got my 8KX and bought 2 lighthouses 2.0 separately. Everything worked fine for 2 days.

When I started everything up on the 3’rd day neither PiTools nor SteamVR could see any of my 2 base stations.

I’ve done the following

  • I’m not using extension cables

  • Made sure both base stations can see the headset

  • Checked that the base stations have a steady green color.

  • Both stations work on different channels

  • Both stations can see each other

  • Tried using only 1

  • Checked that the tracking mode in PiTool is set to Lighthouse

  • Turned the base stations off and on again. - Multiple times

  • Restarted PiTools - Multiple times

  • Restarted Steam VR - Multiple times

  • Restarted the computer - Multiple times

  • Switched USB ports - Multiple times

  • Switched display ports - Multiple times

  • Deleted the configuration files in:

  • Reinstalled Steam VR USB drivers by going to:
    Steam VR / Developer / Developer Settings /
    Remove all SteamVR USB devices

  • Reinstalled PiTool

  • Updated PiTool

I’ve sent a ticket to support. No solution so far.


Sometimes LHs come without correct firmware, so only other HMDs with LH support like valve index, vives can be used to update firmware there, although Im not sure if it’s the case with yours

As it was working the first days, do you remember the channels of the lighthouses when working?

I have to do the following for my 8kX to be detected by pitools properly:

  • turn on lighthouses
  • turn on PC
  • put the 8kX in a position where it is seen by the lighthouses
  • start pitools
  • Plug in dp (if not already plugged in, not crucial)
  • Plug in usb 3.0 first
  • after a few seconds plug in usb 2.0
  • twist and turn the 8kX in front of the lighthouses if not detected immediately
  • check in the 8kX if the Pimax logo is shown.

If the screen stays blank, unplug BOTH usb plugs and replug with usb 3.0 first.

Somewhere in the forum is a batch file which deletes all files in directories linked to a pitools install. Worth a try.

Do you have another valve tracked device to try? Vive/pro/cosmos?

I’ve had the same issue as you describe with my 5k+ several times. Try this:

  1. Set “9-axis” tracking in pitool
  2. Exit SteamVR (wait for it to fully close)
  3. “reset service” from within pitool…
  4. With service restarted and hmd online, start steamVR and let it load.
  5. Change tracking in pitool back to “lighthouse”.
  6. Reboot HMD in pitool (optional)
  7. Reboot computer (optional)

This always works for me.


I think when they arrive they are on channel 1. They collided with each other at first so I did one click and it all worked. So my guess is I have 1 on channel 1 and the other on channel 2.

Sadly no.

That sounds good. My guess is some file is breaking everything. I will try to find that file. I deleted as many files as I could find before but something may still be left broken.

I’ve tried similar ways before and I also did exactly what you said yet again to make sure. I also tried mr.uu’s system but sadly nothing worked.

Thank you everyone for all the help. So very nice of you all to try to help out.

After talking with the support they said they are sending me a new one. I’m so surprised this couldn’t be fixed with software. Maybe it was because I also had snowy pixels and stripes over the screen at times. This issue was not all the time. It seemed to happen more often in large FOV.

I think you are referring to the batch (.bat) file listed in this topic.


BAT file content

@taskkill /F /IM PiTool.exe
@taskkill /F /IM PiService.exe
@taskkill /F /IM pi_server.exe
@net stop "PiServiceLauncher"

RD /Q /S C:\Users\%USERNAME%\AppData\Roaming\PiTool

RD /Q /S C:\Users\%USERNAME%\AppData\LocalLow\Pimax

RD /Q /S C:\Users\%USERNAME%\AppData\Local\Pimax

RD /Q /S C:\Users\%USERNAME%\AppData\Local\PiTool

RD /Q /S C:\ProgramData\pimax

set /p WAIT=PiTool folders were removed. Hit ENTER to continue...

Just make a new text file, paste the code, save, and change the extension from .txt to .bat. Then you can run the batch file by double-clicking.


I have had similar problems with my LHs . During first detection I’ve raised distance between HMD / LHs up to 2 meters and turned HMD around 360 degree and that somehow helps

They’re sending you a new 8KX or base stations?

First they wrote:
“You can return for replacement. I will submit the RMA for you.”

Now I got another message:
“I have sumbitted the RMA for you. When it’s approved, I will tell you how to return.”

It’s seems that’s the solution they are considering. I was not the one asking for this. I told them I was surprised there wasn’t a software solution.

They came to the conclusion after they took a look at:
“C:\Program Files\Pimax\Runtime\lighthouse console.exe”

Maybe they saw something there that meant it’s broken? I don’t know.

I have to say I’m surprised at how fast their support has responded. They’ve been doing a really good job so far.

I will keep updating this post to let everyone know how things are going. Might be useful for others with the same problem.


RMA has been approved. I’m shipping the headset from Sweden to a warehouse in France.


Do you know what they did with it?

Be sure that you have set one LH to channel 1 and the other to channel 2

They did nothing. They only wanted to see the initial info which looked like this:

1 Like

When I got the 8KX and it worked, the lighthouses arrived set to channel 1. It didn’t work correctly of course, BUT one of them still showed up. So even if you set it up wrong, you will see 1 lighthouse. When it broke I couldn’t see any lighthouse doing everything I wrote in my initial post and more.

1 Like

If this is the output from your 8k-X then I can see what the problem is. The USB device, responsible for lighthouse tracking of the headset, is no longer detected by SteamVR. You have only two radios detected (which are used to pair with the controllers). Looks like a hardware problem indeed.


A small tip…: I case you installed Steam VR BETA then that is the reason why you cant see your vr headset there… there is some kind of “steam container” bug i have reported it and the steamvr devs are working on a fix. Select the ordinary steamvr that is working.

Regarding your headset not detecting the lighthouse then im not sure why i only hae the pimax 5k+ but when it have issues i press reboothmd and restart device after each other… then it turn on some kind of diagnose software that reset some stuff and then normal it will work again… Also try to update your software and firmware of your vr headset… AND be aware regarding the 8kx that there is actual a brand new version of pitool that i think you guys maybe need… you can find it on the forum and its named
Pitool so if you dont have that version then try and find it.
Found it for you :wink: the new version also make Eye tracking compatible with the headsets. ( if you buy eye tracking there is also an eye tracking Bios firmware that need to be installed in the eye tracking when you get it by the way…!!
August 15, 2020 Pitool with ET https://pitool.pimax.com/PiToolSetup_1.0.1.263.exe


I did not install Steam VR BETA.

I did try all of that and more and it still didn’t work. This may be because my headset was actually physically broken like “risa2000” said.

I tried both with an older version of Pitools and a fully updated version. There were no firmware update for me to use.

I’ve heard there are some serious issues with this version so I guess that’s the reason why they haven’t put it in the PiTool auto update feature. Still nice for those that want to try out their eyetracking. So thank you for posting it. I sadly can’t try it out myself as my headset is on it’s way to France and I have no clue when I get another one.

Thanks a lot Delevero and others for trying your best to help out. I’m quite amazed that so many people spend their time helping others when they could have spent that time playing and having fun.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.