8K X Occasionally Blacks out for a few seconds (Potentially Solved, EMI Ground Loop/ Interference likely the cause)

Hi Everyone!

I’d like to find out if other people have also noticed this same issue. I tried the default cable and I am now using the OPTICAL Cable and since using the optical cable, i’ve had my 8k x black out randomly for anywhere from 3-5 seconds and it’s happened 3 times. I since upgraded to a 4-port 4-controller pcie internal USB hub and if I remember correctly it’s happened with the new usb controller also on the last time. Since updating to 269 pitool, it hasn’t happened again yet. I also got a replacement optical cable just to see if that’s the issue and I received that today so I’ll keep an eye out for it but it’s so random and unexpected that I dont know when it could happen.

It’s still stayed connected to the game. Game audio still works. Just a complete blackout for 3-5 seconds and it comes back usually.

2 other people told me they have the default cable and also had the black outs happened to them and specifically in iRacing.

I am trying to find out if others have noticed their 8K X and in iRacing have had this happen (or in any other game really).

Anyone else notice this please respond and let me know your PC Specs, which cable, pitool version, and what game, also any other specs that might find a common issue between anyone else that noticed this.

My PC: 9900KS, 3090 FE, 32gb@4000, m.2 Nvme drive with a
Fanatec DD2, 8k x, PT-Actuator’s motion rig


The black out may happen in any game and is not linked to cable type. I’m not sure if it started related to last firmware update. However, it’s only happening once a day or less for me so not a severe issue.


I raised just this issue here:


1 Like

I have indeed experienced this. It only ever happens in iRacing and somewhat infrequently. Usually it happens during the first 5-10 minutes of in-session time for the evening and doesn’t happen again for the rest of the night. Just as you described, ~5 seconds of black headset, then it returns and works fine.

I’m using the stock displayport cable. This has happened with multiple Pitool versions. 9900K, 1080Ti, 32GB, SSD.

BTW what are your SteamVR supersampling settings as well as your iRacing graphics settings? I’m curious if you can run iRacing’s settings maxed out (with the exception of the HDR, heat haze, etc. section) with the 3900. I need to run everything fairly low to get a steady 75fps with my 1080Ti.

Thats for a different section but no i dont max everything out because theres no need to.

1 Like

My issue is similar but not the same. Sound doesnt drop out. Game still keeps going. it was just a blackout for 2-5 seconds.

1 Like

So your observerd blackout behaviour is not accompanied by USB disconnects, audio switch from HMD to PC, then back to HMD because SteamVR forces sound to the HMD if configured so?

Just black sceen for a few seconds and then back to stable with no flashing?

Do you have your DP and/or USB extended?

Its happened with my optical cable and yes only a blackout for 2-5 seconds. Game still connected. Sound Connected. Just blacks out and comes back. Only happened in iRacing i believe 3 times maybe 4. Very random and the game comes back except when in a race it happened once and i almost crashed into other cars and destroyed my own car. I now have my Optical Cable connected to a new internal Pcie 4-port/4-controller usb 3.0 that i got. It seems to be doing fine so far but its so random that i have to continue playing to see if it happens again.

No extenders used.

I know some of the engineers at iRacing and will ask them about it.

1 Like

It happened once to me with MSFS2020, it hasn’t happened again.

You’re the man thank you. Let me know

This happened to me once last night while playing A Wake Inn. Screen blacked out for a second and sound continued in the background. Never had it happen before so I figured it might be a one off thing or related to my upgrading Pitool recently.

I’m on Pitool 269 with the standard cable. I have an i7 7700K with 1080ti and 32gb ram.

Now the right screen goes black after a minute. Well done Pimax…

1 Like

I think something between nvidia and pimax is causing it to have issues pushing this massive resolution

Have any of you incurring this problem tried disabling G-Sync?

I notice that when PiTool acts up, any mouse movement across PiTool‘s window will cause screen flicker and lag akin to super low refresh rate.

I haven‘t had any blackouts since the fw upgrade but mused this might be related.

I never turn on gsync in game

Same occasional black outs on IL-2, a few times in last 3-6 weeks. Nice that is ok after 3sec.

1 Like

Today I had another series of blackouts in ACC but not accompanied by losing sound to the HMD or USB disconnect sounds.

This was after the fw upgrade.

It’s not a per game setting but either enabled or disabled via the nvidia control panel.

I always have it turned on but will now turn it off and see if it affects stability positively.

G-sync can be enabled per application / game in Nvidia control panel, I do that for some games :grinning: and the Mine is better than yours 3DMark :grinning_face_with_smiling_eyes:

1 Like