8K Plus Blacking Out in iRacing (solved)


I’ve been a Pimax “evangelist” in the iRacing community since the 5K BE. I’ve had few, if any, problems, but I’m seeing something new now. Hope you all can help me.

During watching replays especially, but occasionally even while driving, I’ll lose image in first the right, then the left eye. After a handful of seconds, the images come back simultaneously. This cycle keeps repeating. The sim usually doesn’t crash; it’s only closed once or twice with no logs created.

I’ve tried the last three or four versions of Pitool, and the last two Nvidia Geforce drivers (I’m running a 2080 Ti). Blackout behavior persists in all cases.

My Pitool render is set to 1.0 and SteamVR set to default of Auto (in my case, 134%) with app multiplier at 100%. IIRC, resolution is about 2500 h/v per eye.

Thanks for any help you can provide–I hope my HMD or GPU isn’t failing!

I hope so too. Some others have reported issues in the right eye of the 8KX when running in 114 Hz upscaled mode. I haven’t seen any solutions yet.


I’m thinking it’s headset firmware, that I need to go back two releases to be certain. I will investigate.

Update: this isn’t a new problem. It’s occurred in this past (closed) thread:


I’ve submitted a support ticket. We’ll see what happens.

Have you watched the steamVR status monitor when this happens? Any searching for headset or controllers?

I’m very happy to report that I filed a support ticket and Pimax solved this problem within a matter of a few hours by sending a firmware for me to flash. Their customer support was excellent.


Will future firmware updates incorporate this fix, or am I “stuck” on this firmware now? Is the need for this special firmware something particular to certain 8K PLUS HMD’s?

1 Like

Likely when the next pitool is released a new firmware will be pushed out that has the fixes in the firmware you received.


I have the same issue! worked perfectly, than i was 2 Months away and got the new firmware and PItool version now my righteye turns off than the left… the headset stays black for 5-20 secs comes back on and repeat this in like 1 minute later… unplayable! i didnt change anything but the new firmware and pitool version! my firmware update failed first 2 times and was working on try number 3… i did use the firmware flash tool and recovered my firmware backup, than i had to update the firmware again it worked but still i have the issue that the display turns of for 10-20 secs in game and keep doing it like once every minute

Open a support case and they’ll send you firmware that fixes this. Mine has been perfect since then.


Hi tbhausen,

Have your problem:8K Plus Blacking Out in iRacing been solved?
If not , you can make a ticket for help in helpdesk.


Hello again… it seems 270 firmware has reintroduced this problem when running Pitool For the time being, I’m DFU’ing back to firmware P2_D264.dfu that was sent by support to solve this issue. The issue only seems to occur when viewing replays in iRacing. Can you please incorporate a fix into the running production firmware? Thanks!

1 Like

Forward this to Alex. Hopefully they can look into fixing this in a future firmware release.

Could you share the firmware with us, I have the same problem on other games. And I had all these problems with official firmware…

Do I need to forward this to “Alex” or did you do that? If so, who’s Alex? Thanks.

1 Like

How do I upload anything here other than the supported image file formats?

1 Like

I have forwarded this to Alex already. Hopefully next release they will have things fixed up.

Other file formats require using a file sharing service. Ie Googledrive or sites that host file sharing.

Ugh… I’m trying to DFU back to P2_D264.dfu and it keeps hanging at 98%. Any ideas how to resolve this? I tried rebooting the PC. I don’t want to post it if it’s going to cause this kind of trouble for you (or anyone else).

DFU.exe isn’t reporting HMD, firmware, or serial number if that’s any clue.

Edit: I just got it to flash. I don’t know what the hell did the trick… now to see if the problem is once again resolved…

Ive recently had 3 times (very random) where both screens black out for a few seconds but come back. It happened once on Nordschleife and caused me almost to crash. Wrote pimax support. They sent me a debug firmware that i already had and was on. Not sure what it is but i RMA’ed the optical cable. Hopefully the new cable that comes in doesnt have this issue.

1 Like