8k: Need help upgrading from PiTools .91

I have a Pimax 8k, that has been working very well so far for what I have been using it for so I have not bothered to upgrade from PiTools version .91. Now with Half-Life Alyx being here I need to upgrade to a more recent version, but I am having problems.

Trying to upgrade by going through PiTools does not work, it just says “No new version found”. I assume this is because my version is so far behind. So what I have done is removing my old PiTool version, deleting all Pimax folders in AppData and tried to install the only versions I found on the Pimax site (.255 and .258). When I do this I get the same error every time: “Diagnose 10600, Pimax disconnected”. I have tried all combinations of plugging the cables in different slots, starting with it powered on, unplugged etc. PiTools never recognizes the headset.

Luckily I have been able to remove these new versions and go back to .91 and everything works perfect again. I assume I might be having problems because the jump from .91 to .258 is to large, so I would like to try some versions in between, but all of them have been removed from the Pimax site (have tried all the links in the forum).

Does anyone know where I can find older versions of PiTools, or still have them? Or does anyone have any idea of what else I could try? Please help me.

If it matters I am on version 1809 of Windows 10, using a 1080Ti and using latest Nvidia drivers.

1 Like

I use 249 which you can get here


If that doesn’t work I would contact support. As you suggest, you may be too far back and many of the incremental links are dead now.


Welcome to the OpenMR forum! Were you a Kickstarter Backer or pre order?

Here is a link to some of the other Pitools. Newer versions is best though.



Thank you @Heliosurge. Was an early backer.
Late here now, so will try tomorrow if I can get that to work. Just scared I somehow messes things up and bricks it, because I really love my Pimax.

1 Like

Well the good news Pimax headsets are hard to perma brick in my experience. Backer bling added.

Support is very helpful as well if you run into a firmware flashing.

1 Like

Quick update. Installed the .129 version Helio provided me with, that upgraded the firmware in the headset and I was then able to install the latest version of PiTools.
Everything works good now. I think Pimax should keep that version on their site so other people have a place to get it if they have same problem.
Thanks to everyone who has helped!


Glad you got it working. Yes Pimax should not only leave up all the Pitools, they should keep the release notes and what Pitools require which firmware versions as well. You can only go back so many versions now before needing to flash an earlier version of firmware as well.
This should all be kept available and kept current. @PimaxQuorra


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.