8K arrived the 22nd october 2018(Ludx) (French and English Reviews)

There it is !

Been trying to get it “connected” for about 30 min now, closed antivirus, ran and intalled as admin, unplugged , reboot.
Nothing, it still disconnected.
Buttons sound are working, detected by window as Pimax P2A.
Downloading pitool 84 to try it out, was on 76.


Now my first impressions :
Field of view is great, not opressive, can breath in there. No step back.

SDE, it is present, Iam SDE sensitive and I can cleary see it on the 4k. Its slightly more present that on the 4k, for a still image, the 4k as a shaper image, less fuzzy and can see further away details. But no ghosting and good tracking make it better. No matter the resolution, I could almost count pixels, for instance I can count on small text letters are made with ~4 pixels wide, I see pixels and between them. Coming from the Vive (not the pro) the image is of course wider and sharper, less SDE, very good. From a 4k it could look like an ghosting and FoV upgrade.

HMD is lightweight so it fit good on head but with low IPD settings my nose get crushed between lense and is painful,

Tried several games, most run good :smiley:
I dont know how many fps.
Nothing changed in setting in Pitool and SteamVR and parallel projection activated.
Skyrim, ok.
Fallout 4, no way.
Arizona Sunshine, ok with mid textures.
Firma, ok with low settings
Ultrawings, not ok.
The lab, ok but the landscape thing.
BeatSaber, lol ok.
Elven Assassin, ok.
Sacralith, crash.
Pavlov, very ok.

Need some sleep now ^^


After some hard time to get this work correctly, I had great moments yesterday.
I figured out that large FoV was some kind of bugged, despite Pitool settings and SteamVRSS I cant get something else that a blurry image and/or gliched display (wrong eyes displayed, and tracking crazy…).

But with small and normal FoV, man this was really better, Pitool settings was according to Steam and image was much MUCH better.
Like I wish I woud have seen this the first day.
Played DCS and Project cars (PE), both were really good, was able to actually see further that 20m away.
In Arizona SunShine, for a 10/15m away zombie, I was like "Ok you, I shoot you in the left rotten eye

No need to say that in “small” (yes “” because its really not that small actually) FoV I have no problem running games, except Fallout 4 of course :slight_smile:
Dont ask me FPS, Iam just enjoying it,
I found out that with larger FoV you get sick easier if game shutter, like in the 4k for instance, so they run smooth or I really dont like it and wasnt used to this one he 4k when I had it with my previous, old GPU.

Think Iam happy with it :wink:
Running on a 1060Gtx6 btw ^^
With a I-7 7700k@4.2 and 16go Ram
On a MSI Z720 ProGamingCarbon motherboard.

EDIT 3 :
There is a quick review in french and a reading test :

New reviews, in french and english after 10 days of use of the 8k.

New GPU with IL-2 Sturmovik :

Zero Caliber on the 8k !

In Death :

Asseto Corsa :

1 month review :

1 mois après :

Project Cars 2 :

6 jeux à travers la lentille en 4k :

10 FREE Games that worth it with a PIMAX 8K :slight_smile: :


Your headset is 8k right?

1 Like

Yes 8k
Will post pics later and first impression but I want put eye in it first ^^


I think you are on the right track as other backers have had the same problem and indeed it looks like you need PiTool 84 for the 8k .


Congrats. If the headset updated firmware you will need 84 to get it to connect. If 84 has trouble installing. Install 76 & let it update; install as admin.

I only use Windows defender & had no difficulty with installing.

See my topic on settings used. Recent info though leave hidden mask on.

Please post your computer setup as well.

Also if text seems more blurred after setting ipd try positioning headset higher & lower on face. Sweetspot is decently wide left to right but vertical placement is tighter.


Thank you,

Yes I got it somehow working with 84.
But when I turn lightouse tracking on, the HMD display a blue greyish screen and is not tracked, when I turn them off I have display but no tracking.

Got a i7-7700k @4.2
16go RAM
1060gtx 6go


I remember having to go through some seriously technical efforts to get my Pimax 4K working two years ago but I was kinda hoping that was no longer needed anymore. (Had to go into BIOS and disable the onboard GPU)

4k and Vive works fine.

Just when I turn lighthouse tracking, the HMD is no longer tracked and display grey screen.
Front led blink, sometimes but not after reboot.


The hoop jumping never stops.


Have you paired the controllers with the headset?

Yes I’ve been able to, but the headset display nothing.
To get something running, like pimax/steam vr startup, I have to turn off lighthouse tracking :frowning:

BTW the SDE looks like similar to the 4k yes but with better response and not ghosting, I might be better in game but its not what I was hoping few months ago, I know it will be great in game the FOV feel…natural, just want to launch a game now !!


Have you set up room scale on PiTool?

1 Like

I can do it with lighthouse disabled yes but its not tracking it since lighthouses are off.
But when I try to do it when lighthouse enabled the headset is not tracking and display grey.

1 Like

Yeah I don’t really know anything about lighthouse tracking as I only have a rift . When I set up the rift for room scale I have to trace a play area with one of the touch controllers with I can see on the monitor and then the headset works. I thought the setup process would be similar on the pimax .


This forum is always quiet this time of the day . I am sure someone will offer some possible solutions soon . But damn it would be nice if pimax had someone here to help backers with there new headsets.


I’ve send @Pimax-Support a skype message about it, hope I can get some help, dunno what to do now.

Reinstalled SteamVR, Pitool both version several times, uplugged everything, lighthouses and hmd, etc etc.
When I click on lighthouse tracking it just goes grey and as soon as I unclick it its come back to Vr Startup(come landscape on a planet).

Tried a lower Pitool rendering and now its no longer working at all, unrecognized usb error …
Now its a dark screen with a square changing color and position, mostly out of the fov but can see it but back to grey after a on/off lighthouse tracking.


Is your motherboard USB up to scratch?

I had to buy a dedicated 4 port USB card for my 3 sensor Rift with an old motherboard as it did not supply enough power (I assume all the ports were splitting just one USB controller on the motherboard). It disconnected random ports constantly.

As soon as I plugged in the new USB card everything (Rift) works great. Mind you, 2 sensors worked fine without the USB card. It was the 3rd sensor that tipped it over the edge.

What is you full system spec?

  1. Launch Steam
  2. Click Help -> System Information
  3. Copy / Paste that in here

I have almost all usb ports free and its not an old MB.

Computer Information:
Manufacturer: MSI
Model: MS-7A63
Form Factor: Desktop
No Touch Input Detected

Processor Information:
CPU Vendor: GenuineIntel
CPU Brand: Intel® Core™ i7-7700K CPU @ 4.20GHz
CPU Family: 0x6
CPU Model: 0x9e
CPU Stepping: 0x9
CPU Type: 0x0
Speed: 4200 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Unsupported

Operating System Version:
Windows 10 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: NVIDIA GeForce GTX 1060 6GB
DirectX Driver Name: nvldumd.dll
Driver Version:
DirectX Driver Version:
Driver Date: 10 10 2018
OpenGL Version: 4.6
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: NVIDIA GeForce GTX 1060 6GB
VendorID: 0x10de
DeviceID: 0x1c03
Revision: 0xa1
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 27.48" x 15.47" (31.54" diag)
69.8cm x 39.3cm (80.1cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 6143 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: C32F391 (NVIDIA High Definition

RAM: 16343 Mb

UI Language: English
Media Type: DVD
Total Hard Disk Space Available: 3123358 Mb
Largest Free Hard Disk Block: 262896 Mb
OS Install Date: janv. 01 1970
Game Controller: None detected
VR Headset: None detected

1 Like

It might have something to do with your video card being below minimum spec .


It works fine without tracking activated, even if not in game, in steamVR setup or Pimax VR setup it run flawless.
It if because of this, its just intented for selling cards or what…

1 Like