5K+ not working after firmware update

I started up my pimax for the 1st time in a while and it worked fine I was in the alien environment world room scale was working but none of my steam games would load. I got the message need to launch steam VR but steam wouldn’t recognize the pimax, I’m guessing the new steam VR didn’t work with the old pi tool. Since it was a while since I updated the pitool I downloaded the latest version from here. https://pimaxvr.com/pages/pitool
I installed it and one of the first things it did was update the firmware on the headset which I got a success message for. Then I tried to start up the headset. My monitor flashed for a few seconds and then for about 2 seconds I was able to see my desktop sideways in the headset. The screen then went blank but the green light was still showing on the headset. I tried restarting my computer, reinstalling the pi tool but the same thing happens and the pitool doesn’t seem to see the headset at all. I get the Disconnected Diagnose (10500) error. Steam VR still doesn’t see the headset.

what version of nvidia drivers, try to install latest (436.30)
as long as the hmd led do not flash in multi colors the firmware will be ok, if its green then the firmware came up ok and the hmd is running


Thanks that actually worked. Steam VR is still not seeing the headset so I’ll have to figure out what is happening there.

1 Like

reinstall latest pitools
pitools tells steam where to find the plugin/driver for the headset (inside the pitool folders)
there was a short time where ms defender prevented installing parts of pitool and the driver was not installed (you might “trust” the installer inside your av solution)
you can check if the files are at least present, look for this
C:\Program Files\Pimax\SteamVRSupport\drivers\aapvr\bin\win64\driver_aapvr.dll
C:\Program Files\Pimax\SteamVRSupport\drivers\aapvr\resources\settings\default.vrsettings