5K+ & Elite Dangerous visual blurring. Any ideas or help? [SOLVED]

Hi everyone,

I’ve posted this in the Elite Dangerous forums, but I thought I’d try here as well.

I’ve been using my loan 5K+ for ED since I got it, and it was working fine. I’ve been able to play Elite with it all looking great. However, I stopped using it for a few months while I was on the DW2 trip, but kept updating the Pimax software and HMD firmware as and when new ones came out. I’ve recently tried it again and now I’m getting a strange problem that I can’t seem to find any information on, or fixes for.

The problem isn’t easy to describe, so please bear with me. For each eye’s screen, the image is clear on the edge periphery (so on the outer edge), but as you look closer in towards the centre, the image becomes more ‘double’, almost like it’s being smudged. By about 60% across, it’s got to the point where text is unreadable. It’s only in the horizontal plane, and I’ve made sure the lenses are clean and scratch-free. It also doesn’t matter where I point my head, the smudge distortion is always on the inside edge of the two screens, nearest to my nose, slowly becoming clearer as you look out towards the periphery of each screen. It’s almost as if the ‘sweet spot’ is right on the very outer edges of each screen/eye.

I’ve tried going back a couple of PiTool versions, but no luck. I’ve tried other Steam VR games and they all look normal. ED is the only thing (that I’ve found so far) that’s doing this. ED looks normal on startup, with the Frontier logo fine, the ED logo fine, and even the parts where it caches the data, all look fine. It only kicks in when it goes to the main menu, and is the same in game too, making ED unplayable for me in VR now. I’ve even tried turning Parallel Projections off, just to check, and with that off the image is back to being clear right across each screen, from outer edge to in by my nose, albeit screwed up because PP is off. So I know that the hardware and lenses are also fine.

If anyone knows what’s going on, and/or has any ideas about how to fix it, then I’d be forever grateful. As it is now, I can’t use my Pimax for the one purpose I got it for.



1 Like

That’s odd. Check both your manual and software IPD settings. Do they match what you remember? You could try setting the software IPD to 0, set your measured IPD using the headset wheel, then use the software IPD to tweak things, if needed.

ED’s intro is basically showing a 3D movie, not rendering a 3D world, which explains the difference in behavior. I played last night and it was fine, so it’s not some new ED issue.

1 Like

Thanks for the suggestion. I had already played about with that. I’ve always had the software set to 0, and the HMD set at my IPD of about 63.5. I’ve tried moving both the hardware and software, but the double image remains no matter what settings I use.

If I close one eye and look with the other, I see the image clear in the outer edge, and blurring more as I look in toward my nose. If I do this with PP off, the whole image is clear from edge to edge. I’ve tried looking closely, then fixing my eye on one point and moving my head slowly (keeping my eye on the same part of the image). As I do this, I’m fairly sure I can see alternate pixel rows separating out, almost like a zipper undoing.

The thing is, the duplicated image on my monitor looks just as it should, perfectly fine. I normally run ED from the Frontier launcher, but I’ve also tried installing and running under Steam, and it’s just the same there too.

I’m wondering if I’ve had a bad firmware flash, but then why would other games work ok with PP on? It makes no sense that PP off, image is clear in each eye, but PP on and each eye gets blurrier the closer I look toward my nose. This is driving me crazy!

What you are describing is in fact IPD being off. as Pimax releases newer piplay version i have noticed that i have had to ‘tweak’ my IPD on the software after each version release.

It has been documented many times on the P4k forums where the edges are clear and center is blury… 90% of the time it was related to IPD values being wrong. and the odd 10% being faulty lens… but i dont think that would be your issue if it was working before.

Note you can change the IPD values in Pitool while a game is running… so should not be too hard to make those fine tuning changes.


1 Like

Did you ever change your “maxRecommendedResolution” default.vrsettings ?

consider clear installation of pitool and nvidia drivers, wipe out all vr settings…

Forgive me if I missed you answering this already, but have you played/been able to play other VR games?

@Enopho - Not IPD settings. These made no difference at all.

@Possyguset - No, not changed that, not even sure where to change it! :slight_smile:

@Yata_PL - Yup, spent a couple of hours this evening doing all that. Reinstalling older versions of PiTool, even tried an old firmware. No effect, still blurry.

@mp4x - Yes, I’ve been able to play GizmoVR Video Player, SkyrimVR, SteamVR Home, and something called Sheaf - Together EP (it’s a VR music video with realtime 3D graphics in a car). All without problems.

Thank you all for trying to help, it is appreciated. I also posted my problem on the Elite Dangerous VR forum, and had a couple of replies. One of them lead me to the fix.

Someone said they had slight blurring when they had Smart Smoothing set to ON. I had this on. Turned it off and instantly Elite was back to a clear, blur-free screen. I had no idea that SS could produce this blur effect, and it seems weird that it’s only in Elite, and only when Parallel Projections are also on (which is needed for Elite).

So, thanks for all your suggestions. I do love a good, helpful community, and I hope this post might help someone else out in the future! :slight_smile:

-=] Darkcyde [=-


I got blurring when FOV was set to wide, it was ok when set to nomal or small, never had a problem with Smart Smoothing though, very strange.

1 Like

I may play with the FOV, just to see what happens. I’ve had it set to normal this whole time though, as my GPU isn’t as powerful as I’d like. I’m waiting for my 8K-X before I think about upgrading.

1 Like

Wide results in blur for any game IMHO

1 Like