5K+, 2080ti, Gen 7 i7, 32GB RAM - All games play badly

Hoping for some ideas - I have had Oculus Devs kits, an HTC Vive at launch and of course my Pimax 5k+… When I originally received the 5k+ some games played fine, many wouldnt load, etc… but at least some played fully.

I had to travel a bit for work and after a few weeks I did some Pitool updates and of course FW update - and I had some issues and I held out for the new release today of the pittool and the nVidia drivers. I was hopeful it would fix something, but I still have horrible luck on anything playing well.

Even Spiderman homecoming gets me sick quickly - My FPS are pretty bad and if I have SteamVR show GPU stats in the headset I am always above 16ms or more - some games hit 50+

I have changed SS, pitool max / etc… My default is pitool on 1 and I have lowered all games to 20 or 30% and still, unplayable FPS…

Right now Im very frustrated and hoping the group has some ideas? With the 2080ti and my typical gaming rig, this should have more than enough power to drive what Im playing…

(Of ourse, I still cant get Marvel Powers United to play and that is all Pitool’s issue, its one game I really wanted to play on the 5k)

Start with normal FOV and PiTool at 1.0. I would disable brainwarp as well.

Steam apparently doesn’t like it if you go too low - someone else found if they set 20% it would reset itself to 100%.

Make sure that the “Pimax Home” is unchecked in Pitool. That eats a lot of CPU and GPU running in the background. That’s the planet landscape that you see when you have the headset turned on without any games.

I don’t know the games you are trying but not every game can run at 90 fps on the 5K+. Check Svewiver and Voodoo DE videos for their fps numbers as they have similar hardware.

I’ve also had both dev kits and the vive. I haven’t run into any performance issues with the 5k, but I play main iRacing. I’ve confirmed good FPS in a couple steam games but havent dedicated any serious time other than Arizona Sunshine and a couple other shooters to make sure the combat scenes were smooth.

I have a lesser GPU than you (2080) cpu is a 2700x. So I would expect the intel cpu to push ahead slightly base on base clock speed since most games are single threaded.

Most games are at 1 pitool. 100% steam. But i might have changed Arizona to 80% in steam. I’m away on business so can’t grab the exact steam vr settings, because the headset isnt on when i vpn in.

Maybe you can run a logging tool to try and identify where the bottleneck is. in Iracing its pretty simple it will show you the cpu, gpu thread percentages.

Thanks for the suggestions all around - So I did try it without loading PiHome and it was still pretty bad - Frames always above 10ms. Disabled Brainwarp - not much of a change, and my standard use is Normal FOV due to the distoration being annoying on the side…

What I did discover looking at everything now is that a lot games I want to play required Parallel Projection and thats is the main issue I am having - If I load the game without Parallel enabled the timing goes down to 3-4ms - enable Parallel again and unplayable…

So the most depressing thing right now is that I have to use my Vive more than my 5k now…

Neighbor was excited to try John Wick, but I had to put him in the Vive since the 5k requires Parallel on and even on the home startup screen for John Wick it was pushing 12ms, so every time you move a bit it gets blurry and the timing can jump to 15-20ms.

Marvel Powers United - still wont load on any setting and my other favorite game, VR Sports loads ok but the floor is so high that as a Goalie in Hockey the ICE is the height of my waste.

I think the HW is great but its about 60% unusable for me… That wouldnt b so bad overall except that since I have experienced the 5k when it works, the Vive is SO tought to use, but at least I can play the games :frowning:

** Edit ** Forgot to mention that during the tests the CPU was never over 30% and the GPU load was rarely above 70%

When having issues like these people are suggesting doing a full uninstall of your graphic card drivers and a reinstall. Also might want to try uninstall revive, pimax has built in support for oculus games

Yeah, when I installed the newest nVidia drivers I did a clean install - I usually do a clean every few releases just in case.

I was going to try to uninstall revive - but right now its the only way I can load Marvel at all - Although on the 5k I have to enable Parallel projection, so its unplayable.

So I think my current solution is going to be another install for using my Vive where I can play all of my Oculus games at full speed with revive and the few that I play that work on the 5k without issues, I’ll use a second drive… Not ideal but until (if it happens) PiMax can get games running without Parallel Projection or get all/most Oculus games loading, I dont see another solution.

What is your graphic card ? have you a software for monitoring your card frequency ?
Try with MSI Afterburner, and check your gpu frequency.

I have a rtx 2080 Ti, and a few time the core clock stay at 1350Mhz and not increase at 2040Mzh (the boost frequency for me).

check any app which can override SS like fpsVR, advanced open vr and reinstall steam vr
what resolutions shown steam vr when you had this 16~20 ms ?

There is something wrong and it’s hard to find out. In that case I’d suggest a complete reinstallation of everything, including Windows.

1 Like

You might want to run this utility. It will help you discover what’s wrong with your system (and something does seem to be amiss. It’s been quite helpful for me (personally) and others on this forum. If you see a problem click on one of the “question mark in a circle” icons, to get suggestions as to how to fix a problem.

. https://www.userbenchmark.com/

This might also be helpful…

. https://thebottlenecker.com/

Downgrade your Video card driver and try again… I had issues with the latest driver making everything run really slow, even a full screen youtube clip was stuttering… Downgraded the driver and it fixed it immediately, then reinstalled the newer driver and it was fine…


Some users reported that games would crash because they were hitting the 4096px limit but ran fine when the limit was increased.

Might be worth a try.

1 Like