3090TI & 8KX Compatibility

We are happy to share the latest update with you regarding the compatibility issue with the 3090TI with 8KX. To address the compatibility issue, you might try using DP 1.4 Repeater.

Purchase Link :
Amazon US - LINDY Extend DisplayPort 1.4

Amazon FR - LINDY Répéteur DisplayPort 1.4 12m

Installation :

  1. Plug the supplied power supply to the Repeater and to a corresponding wall socket
  2. Connect a DP Cable to the source DisplayPort socket on your computer and to the Input of the Repeater.
  3. Plug the Headset DP Cable to the Output of the Repeater and to the input of the Display.

Troubleshooting Tip:
If you are experiencing video problems whilst using two different cable
lengths, please try switching the order in which the cables are installed and then restart your

We hope the information above is useful to you. If you have any questions, don’t hesitate to get in touch with us.

I appreciate your patience and support throughout the years.

Last but not least, please shoutout to @cruser_icu who came up with this brilliant idea.


So your saying Nvidia screwed up on DP signal strength?

1 Like

:face_with_raised_eyebrow:The current test results show that it does need to boost the output signal, but there are likely other reasons, we have sent the situation and test results to NVIDIA .


This solution should maybe be explored by folks on the older 8kX. If the team has been able to reproduce the 90hz issues some experience on Nvidia setups.

Considering all other RTX 30series cards work it suggest Nvidia messed something up. The 3090ti required a specific new driver on release that was only for the 3090ti and you couldn’t use earlier driver.


Supposedly the 3090 Ti isn’t actually a 30 series card. But rather it uses hardware from the upcoming 40 series, a forerunner to the new line.

So that does make this issue more generally concerning because it could mean that all 40 series cards would have this same issue as it stands right now. I imagine that makes getting it resolved a high priority for Pimax.

But there may be little Pimax can do about it other than bringing it up with nVidia. Pimax posting about using this repeater to work around the issue is presumably just a stopgap measure until nVidia can fix it.

1 Like

There is a post with one solution being to use a DP repeater.

Post here

It would be interesting to have a dive into the 3090ti hardware. It would seem in part they have maybe downgraded the DP signal.

On the other hand those with original 8kX on RTX camp that have had trouble might be able to use the Repeater to get 90hz working.

1 Like

100 bucks though. Yikes. But you’re right, that may be the product for me, I don’t have a 3090tI, but a 3090 plus the old revision of 8kx…i just get random blanking with 90hz no matter the cable, GPU, mobo, CPU, firmware, pitool version. It seems this would be the last ditch effort for 90hz for me, but I’m not sure I can spring 100 bucks with the 12K so close.


Yeah with the cost will want to order where you can return if it doesn’t work.

It is unfortunate signal strength standards are not very consistent with GPUs it seems.

Imho pimax should look into better testing and if needed look into offering a propietary cable with a built in repeater.

I keep wondering why there is no end-to-end optical video port standard yet, but I’m no engineer – I guess there is some rational reason.

In other news; Reports are beginning to pop up, that problems with intermittent 200%-300% current draw transients (up to 100ms long), which have apparently been with us since the 10x0 series (and AMD are apparently no better), and have been tripping the overload circuitry in power supplies, may become a greater problem with upcoming GPU generations, as the climbing overall power consumption between generations, and the transients along with it, nears the rating of current PSUs…
NVidia apparently likes to blame PSU manufacturers for not putting in large enough capacitors, that they can manage spikes that tall…

(For my part, I have noticed my graphics card fans spinning up mysteriously, now and again, for no apparent reason, with my FE 1080Ti on a 750W known brand PSU, but can’t recall any sudden shut-off events. :7 )

1 Like

It’s why I went with a 1600W EVGA Titanium T2 last time round for the 3090.

I expect it should be enough for the 4090/Ti/AD Titan.


Well just keep in mind bigger has in the past not been bigger where it needed to be.

As was the case when the 2080ti was released. I recall a reddit thread on it.

“1000w Power supply not enough but 650w works?”

Was something like that where the issue was the lower wattage psu had only 1 12v rail with adequate amperage and the higher wattage psu had multiple 12v rails but none had enoigh amperage on a single rail.

But am sure your 1600w one doesn’t have such issues. Lol

1 Like

Oh yes, going by just the wattage of a PSU isn’t the best approach, that’s for sure.

I never skimp on any of the parts in my builds but the PSU is somewhat sacrosanct to me. I had one blow up once when I was young and skint and have since tried to always get top of the line PSUs since then.

Sufficient wattage, dedicated Amperage per rails, high efficiency rating and always from a reputable manufacturer with very good warranty. That way most PSUs lasted at least 2-3 builds before having to be replaced.

1 Like

Would the repeater solve the issue I was having with the Optic Fibre cable with 8K X? Works fine with the standard cable.

Video showing the issue

Video showing the issue

PC specs are:
Win 10
I7 4790K
Asus ROG Maximus Hero VII Z97

1 Like

Based on what you’ve shown in the two videos and written in this post, I doubt it. I don’t think your problems are actually on the video end but rather on the USB side. The USB needs to power the headset and enable the video. It acts like it’s running out of power whenever it tries to power up the rest of the headset and rebooting over and over.

The splitter cable you purchased doesn’t necessarily actually combine the power from both USB ports onto the fiberoptic cable. There are complexities to USB power, and I’d actually be a little surprised if that just worked as intended unless the specific type and brand of splitter cable has been tested to work in this specific use case with the fiberoptic cable by someone who actually has the equipment and expertise to tell.

I also notice that you have a whole steering wheel setup with what looked to be a direct drive motor. The RF interference produced by these motors is known to cause problems with VR headsets, particularly with Pimax. So the first thing I’d recommend is unplugging and disconnecting that steering wheel setup completely. In fact, you should unplug all other USB devices from your PC besides minimum mouse/keyboard and retry testing. It could be not working either because of RF interference issues or power draw from other USB devices.

The next thing I would try (while maintaining everything else disconnected) is connecting the fiberoptic’s USB through a powered USB hub by a trusted brand such as Anker. If not enough power is the culprit, this should definitively eliminate that as a possibility.

My next highest suspicion would be that it’s a bad fiberoptic cable.

Unlike the 90Hz problem, I do see some possibility that the repeater will help here, but I give it very low chances. I’d try replacing the fiberoptic cable first. However, if the reason you want the fiberoptic cable is the additional length, the repeater would provide that with the standard cable you say works, and you could just avoid the problem that way.

Also, if you haven’t opened a support ticket with Pimax, that’s actually what you should do first. You could try these other things in parallel, but I’d consider whatever advice Pimax support has about it to be the mainline toward a working solution.

Pimax support sent a replacement cable and that had the same issues. I’ve already returned the Optic cable as I got fed up with the troubleshooting and reverted back to the stock cable as the 8k x works fine with it.

1 Like

Would really prefer to get this shipped locally in the US. I am in a bit of a hurry to test everything at the moment.

Same, exactly the same. Only I have just optical cable, can not test other cable.


we suggest you to log a ticket at our helpdesk.
Our technician will be help you to diagnose the tracking problem.


1 Like

Still waiting on a new version of PiTool to come out to fix this. EVGA 3090Ti and 8KX. Running Win 11, and the ONLY way I can get this HMD to work properly is (using the two-plug fiber optic cable), start PiTool (version 277) and it recognizes the HMD as being connected, and starts tracking properly.

Then, I have to shutdown PiTool, and install version 270 over version 277. Launch PiTool and it sees the HMD as already connected and starts tracking. Then I can launch MSFS/DCS/ED/SteamVR.

However, if I shut the computer (or HMD) off, I have to install PiTool 277 over 270 and rinse/repeat.

If I attempt to start anything VR with 277 installed, either MSFS detects no VR headset, or SteamVR crashes when it starts.

Have you tried pitool 280? And what firmware and headset are you using?