1st time I tried to update Firmware

Hey fellas,
So I updated the software ver to 280 then decided to update the firmware, and now its dead, had a red,green and blue light blinking on the button?. Said please contact support, I can’t even restore it back so now what?

I fixed it…


how did you fix it ?

I went into pimax folder/runtime/ and ran the dfu app.exe file and it reset back to what I had and worked, so i’m not gonna upgrade it, it’s fine the way it is now for me. It’s a shame though it bricks it when trying to update it, and if you don’t find any info on how to correct it, your out of luck unless someone can help.

1 Like

Oh there is in fact a lot of information about this, just try youtube, for example.
I suggest you to search for intel, before you just do a bios update of your device :wink:

Whether a firmware update for a Pimax hmd fails isn’t related to cpu brand.

It has happened to many people here over different models and with different versions of Pitool and different versions of firmware. Don’t recall anyone being permanently bricked. That being the case a search here (or just a question) will yield help. Also opening a support ticket would like-wise result in a fix so i wouldn’t say anyone has ever been out of luck.

This is agreed!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.