120Hrz issue & Crystal controller(Right hand) not gripping in game but works

A few times I set the HMD to 120Hrz. when I switched on the PPimax Crystal, I just saw a white screen through the eye glass untill I reverted back to 90hrz

The Crystal controllers work but suddenly, all the games dont allow me to use the trigger, or grip in games.
I can see they actually work when testing in steam VR and see movment in game bot dont actuall grip anything or fire a gun. Tried multiple games and this was only happening today, when it worked flawless.

Anyone know what the issue is.

If you’re experiencing a white screen issue, could you please take TTL (Through The Lens) photos and upload them here for further analysis?

Also, could you confirm which cable you are currently using, the FO (Fiber Optic) cable or the default one? And have you updated the firmware to the latest version?

All headset and controllers are updated to the latest firmware.
Also ir is very intermittent so it caught me off guard, but will do so

The controller issue is a weird one as I reset and turned off the controller. Restarted steam and Pimax, still. It’s as if games are not understanding the right controller functions even when toggling
Index controllers in Primax or setting compatability mode or editing bindings in steam VR.

This was in steam VR games, Revive from fps to adventure

Have you tried the option “emulate index controller” in the Device Settings of the Pimax Play?

I found the same bug in some games (in my case Paradox of Hope), and with that it solves.

Thank you for your response @er_garry @PimaxQuorra I have tried this and even restarted pimax and steamvr. I even tried changing bindings to mimic other controllers.

This is a Pimax issue as my vive or mixed reality headset don’t show any of these issues.

I have the traditional cable and now call this a ghost controller as it’s there and works as expected but not when gripping a device in game. If I take my hand away in-game I can see it grips…
Very Interesting bug.

1 Like

@PimaxQuorra Also the 120Hrz issue has gone but I do recall playing for an extended period which could only mean heating issue. PIMAX should seriously consider user being able to have full control of fan settings in their next update and also more controller options.

Will Pimax consider being able to have pimax home/ have any usefullness and allow us to start steam from within the headset ? Even pimax experience should have a simple/script option.

1 Like


This has been shared with the developers, and they will evaluate and consider implementing this feature.

I’ll forward this to the engineers, and hopefully, they can work something towards this.

I have doubts that the 120Hz issue wasn’t caused by overheating. I will ask the team to conduct tests to investigate this further.

Thank you agin for your feedback. Pimax really listens to its customers and this builds trust.

Is there any feedback regarding the Ghost controllers. I have tried again today and I am not able to play almost any games with this issue. This is really a deal breaker as I do not have any issues with either controllers or headsets.

Press and hold the π button for 9 seconds until you see a flashing red light and feel a vibration. This will allow you to reset the controllers.

@PimaxQuorra . I have done this as in my first post. This did not help. note that this was only even after the firmware update and only started recently.

Is the grip button physically stuck, or is it being held down in-game even after releasing it? This information can help diagnose the issue further.

Everything works as norm. I can see in VR the grip/trigger button working. I check steamVR config and see the controllers being pressed. Ingame both buttons create an action. Only thing is when reaching to grip an item, the right controller does nothing.Left controller works. its as if there is a grip/trigger bug in game. Tried in both XR and normal steam. same issue.
Tried changing compatibility in steamVR and in pimax play (mimic index controllers). Tried unchecking gesture control. No luck

Understood! It seems like a known issue related to the right controller’s grip button. Users have reported the exact same problem when using PimaxXR on the Pimax Discord. I’ll include the developers to investigate and work on finding a workaround or fix for this bug.

Thank you.