Updated to the latest firmware on 8K, now I'm getting huge ghosting

Just saw on Pitools that I had a firmware upgrade, and after that i’m getting awful, unplayable ghosting. Any help? can I downgrade the firmware?

Also tried Pimax 8K with my new RTX 2080ti, and maybe it’s the fixed foveated rendering, but i’m getting a terrible shimery halo all around the edge of the screen, this doesn’t happen on the moon demo, only after I run SteamVR. No tweaking of the FFR removed this weird halo, it’s really immersion breaking, I want to remove it completely.

Not directly related, but finally installed the DAS from the backer package, and the comfort is alright, but it’s incredibly difficult to find a spot where the image is clear, where with the old one it’s was incredibly easy.

So after upgrading firmware, DAS and graphic card, my VR experience has gotten really worse surprisingly, to the point of being unplayable right now.


With comfort kit it does take a bit to find the ideal position from being used to old cowl. Some prefer and have swapped back to og cowl.

I’d have to restest again as have a couple of headsets here. Ensure smart smoothing is off. However yes firmware can be downgraded. I did notice ghosting as well on og 8k and will need to see if it was fixed with smart smoothing off or not.

Turned smart smoothing off and ghosting is still there. How can I downgrade the firmware, is it risky?

On the other hand, the shimmery halo was indeed FFR, turning it off (or “close” ??) removed it, and after some tweaking the DAS is more tolerable and I can find the sweet spot a bit better.

1 Like

Many have downgraded Firmware. It should be safe. Did you off hand recall what last fw was? I think it was 255?

@playa has a collection of pimax software & firmware. He might know which one is last and have a copy.

There is a link to his collection in Release Notes category in topic “Pitool & Firmware”


Cool, I found them. I don’t remember exactly what firmware was working previously sadly, I see my current 268 in there, I’d try the previous one, apparently 264. Any step by step guide about downgrading the firmware?

1 Like

That’s the pitool version. I think firmware 255 was the last fw version.

There is a dfu.exe in pitool directory. Launch that and choose the firmware file to upload/flash. Just make sure it is one that is good for og 8k.

255 firmware does look like the last og 8k compatible firmware.


Here is a link to playa’s firmware section.

1 Like

Well that doesn’t look very intuitive to install. I think I’ll wait and see if Pimax can address this, if not i’ll give it a try

Maybe I’m doing something wrong, but I can’t see any dfu.exe in the link you provided on /pimax/pitool/ folder.

1 Like

My apologies.

The Dfu.exe is located in the install directory of pitool.

Once you run that it will show your pimax and ask for a firmware file to flash. That would be the dfu.file downloaded from the link.

1 Like

Cool, thanks, found dfu.exe on pitool\runtime folder. I’ll wait a bit to see if @PimaxQuorra @PimaxUSA can address this, otherwise I’ll try to downgrade to 255, but i’m really scared I could brick the device doing this.

In any case, thanks @Heliosurge for your amazing support, you really do a fantastic job here.


Hi Skyrimer
I’ve upgraded / downgraded my 5K+ and 8KX several times with the dfu.exe tool.
No worries it works as intended, and if it does not go well it can be saved.

Flashed mine 6 to 8 times now I believe without problems.

1 Like

Thanks, very much appreciated! Keep in mind unlike Graphics cards and a lot of other products. Pimax headsets have yet to in my experience having a failure that results in a paperweight. One of pimax’s best features is robust firmware.

Well that’s a relief. Still I’ll wait a few days though, and see if they can add something to this issue.

1 Like

Hello @Skyrimer,

We have acknowledge this issue to the software engineer, he will be check the ghosting issue and try to figure out something for it.



Thanks for the fast reply!

1 Like

The same here in my 8k, 60hz or 70hz, the ghost disappears, at 80hz I leave the brightness at 20, so as not to see the ghosts.


I reported the same issue, still did not have time to figure if a firmware downgrade might help.


I think I read somewhere maybe here that some have used lower refresh and/or brightness setting?

Tried 8k’s max 80Hz but not with lower brightness settings.

1 Like