Unsolved tracking issues with OG Vive wands using 5k+. My observation and speculation

My setup:

  • Beefy 9900k + 2080ti itx machine, asrock z390 phantom.

  • OG Vive Kit, 5k+ (serial 203) shipped and arrived ~March 2019

  • 3* Vive trackers, for VRChat

  • Latest windows 10, PiTool, SteamVR, 5k+ firmware ATM


  • Frequent loss of tracking/connection of Vive wands in SteamVR games/home. The wands can be seen flying around, stuck, unresponsive/delay to button inputs. Games like Beat Saber is completely unplayable, while other games would suffer too.

  • The 5k+ HMD is also vulnerable to tracking issues, if I cover both left/right side while room lights are on. This is unlikely to affect gameplay however.

  • Followed workaround on forum. I tried deleting some files related to lighthouse, disable USB power management / remove and reinstall USB drivers in SteamVR. Tried every USB 3.1 gen1/2 ports.


  • My wands and lighthouse works 100% fine. Just confirmed last night with OG Vive HMD, I can’t find a single moment Vive wands tracking was lost.

  • My 3* Vive trackers worked fine in VRChat with both Vive HMD and 5k+ HMD.

  • The Vive trackers come with watchman dongle USBs. I can connect Vive wands to watchman dongles instead to HMD builtin dongles, by plugging in dongles but with HMD (USB or power) disconnected, then manually pair the Vive wands in SteamVR.

  • With HMD power connected, if I unplug the a tracker watchman dongle, a Vive wand will lose connection. If I disconnect HMD (USB or power) instead, the connection will remain. This proves the Vive wand are connected to dongles instead of HMD.

  • I used 2 tracker dongles to pair 2 Vive wands. No Vive tracker is being used. Surprising it did not improve the tracking of my Vive wands, what the hell? With Vive HMD, the Vive wands are still acting fine. With 5k+ HMD, the Vive wands will still act up and lose tracking.

  • With SteamVR turned off, Vive wands are never seem to act up in the spacey mountain default scene. I will confirm this again.

Other thoughts:

  • It’s unknown that why Vive trackers always work fine.

  • I can’t find anyone experiencing the same problem. But recently similar things happened to users who play Beat Saber with 5k+ and index controllers.


  • I suspect that Vive wand’s data is sent to Pi service instead of directly to SteamVR, no matter I connect wands to HMD or watchman dongle USB.

  • Unlikely the Vive wands would communicate to HMD if they are connected to USB watchman dongles plugged into computer. I want to confirm this but I have no way.

  • The 5k+ HMD (tracking/builtin dongle) is unlikely to be defective.

  • There are communication issues regarding Vive controller between Pi service and SteamVR, which is hopefully a software issue.

Any ideas?

(x-post from https://www.reddit.com/r/Pimax/comments/hm3i1c/unsolved_tracking_issues_with_og_vive_wands_using/)

1 Like

huh… normally we see the index controllers having tracking issues not so much the wands.

If you have a wifi router close to your play area, maybe try and turn it off for a session if possible. just to see if the signal is interfering with the bluetooth radio?

I think the wifi router did not cause it, because the exact setup worked 100% fine with OG vive and wands with tracker USB dongles. I don’t think the wifi router would start to affect the signal between wands and tracker USB dongles when I use 5k+ as HMD instead. But anyway I would try it tonight.

Ah, I thought the problem was while the wand was connected to the 5k+.

It was mentioned in relation to a question on the pimax now event that all trackers and controllers should be paired in the pitool, not steamvr. maybe this is something you could try? since you mentioned connecting with steamvr.

For me it is that the software I have to turn off basestations turn one or both off when I have headset running.

My devices are paired inside pitool normally. Last night I deliberately paired the wands to steamvr (I disabled pitool service, disconnected HMD, plugged in tracker dongles) and see if steamvr can take the control. Unfortunately it did not.

Did you mean you turned off a base station and tracking of both wands worked fine, while using pimax hmd?

The software turns off the basestation when your not using them so controllers and so work, but sometime it miss and turn them off when your playing. It is a 3part software.

What is the name of that software?


Did you try leaving the original vive expansion box connected while using the 5k+? afaik the vive connector box does communicate with the vive lighthouses. maybe it does also somehow control the vive wands? who knows. worth a try.

Thank you. Would give it a try.

Very good news! By following this guide (https://community.openmr.ai/t/why-pimax-has-some-controller-compatibility-issues-with-index-controller-some-info/24313/246?u=saren) after the “unpairall” command in lighthouse console, I paired 2 vive wands directly to watchman dongles in steamvr, and everything works fine now just as OG vive!!! Beat saber no problem!

Guess it is still the issue regarding receivers inside my HMD or processing modules in pitool software. I may have paired my wands to HMD receivers or pitool, which are unwelcomed by my HMD/pitool.

I would have to buy 2 extra watchman dongles now because I am using 2 for wands, while I have 3 trackers…


try pairing only one with the HMD, the other controller with one dongle. maybe you need to buy only one more dongle.

Yeah that would work too. But I would buy 2 anyways for spare and because of shipping cost

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.