Unity tracking issue

Hey guys,
I’m having a weird issue in some games.
Basically when I turn to one spot (always the same), the headset will show me the opposite direction. If I keep turning, it will go back to normal.
I drew a sketch to try and illustrate the problem.!


I first noticed it in Blade and Sorcery. I thought it was a tracking issue but :
It was working fine before update 9.1 where :

  • Updated to XR plugin

And the issue resolved itself with update 9.3 which listed as changelog :

  • Removed Unity XR plugin (hopefully fix a rare crash / black screen)
  • Misc changes for the arcade version of the game

So I’m guessing it might be the unity XR plugin ?
Right now I’m having the same issue with Valheim VR mod, and in the exact same spot.

Any of guys ran into this problem ? Is it Pimax specific ?
Do you guys think it’s game-specific or should I post a bug report over there : https://github.com/ValveSoftware/unity-xr-plugin/issues ?

1 Like

I’m no expert but my immediate reaction is: you have something in the room causing this. A picture, a coaster, a shiny… something. My guess would be that you have a mirror on the wall or something like that as flipping the axis is a bit extreme.

1 Like

Yes that was one of my first thoughts.
But I have thoroughly checked my tracking, upgraded from V1 to V2 LH because of a busted LH V1 and the problem persisted through it.
Again, the issue was only at the time with B&S and it would consistently appear/disappear with the updating and rolling back of versions. Only recently did I pick up Valheim and noticed the same problem.
Only thing I could see is that my V1 lighthouse had a dead spot and that maybe it persisted through the upgrade. But I did a thorough reinstall of SteamVR, Pitool and stuff while debugging. And even then, why only these two games ?

1 Like

For some reason, the valheim VR mod change the orientation of the play space origin when launching. This causing this bug to happen in a different spot in the room, depending on the orientation of the HMD when launching the game, but still in the same spot in relation to the origin (ie when turning to the 4 o’clock position).
So I really don’t think it’s LH related…
The mistery thickens…

Edit : quick vid demonstrating the problem : https://drive.google.com/file/d/1XBLC3sERdGrn_TKVxDYf_mbMaVvXGRzy/view?usp=sharing

Unfortunately this is common, I have ran into it during game development and the only way i found to fix the issue was to reset the standing/seated position. I add the option to reset it through the game but if that’s not an option you can reset it through the steamvr overlay.

I had the same issue with PantherVR. (Also having it with Valheim). The devs from Panther said it has to do with the larger FOV and to use parallel projections until they could figure a fix. It fixed the issue for me in Panther (Haven’t tried Valheim yet).

Makes me wonder if upping the fov in Valheim might help? I’d hate to take the perf hit of pp on Valheim.

Interesting.
I do have Panther VR and I know it was working fine but that was near the EA release, I haven’t launched it in a while, I will give it a shot to see if I’m having the issue.
I do know that parallel projections don’t fix it for Valheim though, as I’ve tried that.

I just tried Valheim with pp on and it eliminated the problem for me. Maybe you didn’t restart steam vr after changing the pp setting? Strange.
It did add some issues with the shadows rendering differently in each eye. I had to turn off the occlusion option to get rid of it.
Unfortunately I’m now having issues getting the resolution to stop changing so I can see the bottom of the craft menu. Oh well.

Damn you’re making me doubt.
I’ll have to try again tomorrow to make sure !

Well I’ll be damned, it works !
Don’t know what I did last time to botch the test but it’s ok now.
I feel stupid now…

For the resolution I’m having good results with 1920*1080. What do you mean it keeps changing ?

Nice! Glad to hear it works.

I kept trying to change the resolution in game to 1920*1080 but it would keep switching back. Turns out I had to change the resolution on my monitor/ old tv first.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.