Though connected, PiPlay doesn't display it

Hello I’m new here - so hello everyone!

For about a year now I own a Pimax 4K. Apart from the typical issues, it worked fine so far.
I didn’t use the VR for the last 2 weeks or so - yesterday I wanted to play again - and since then the VR is constantly in green mode/LED and PiPlay displays that USB and HDMI is connected, but the VR it self is not.
I exported the files with Dr.Pi
Windows 10 64bit
Intel® Core™ i5-3570K CPU @ 3.40GHz
AMD Radeon R9 200 Series -> Sapphire 290 Tri-X 4GB

Since the two week I guess Windows updated the new aprils update (build @ the moment: 1709) and PiPlay is at Radeon driver version is: 18.5.1

Since I’m troubleshooting the problem I did the following steps to maybe get it back working:

  • I deactivated my onboard graphic card
  • Deinstalled the newest PiPlay version and installed: (same problem) then I autoinstalled the first 3.0…version - here I had the issue of constantly connecting/deconnecting HDMI (flickering display) -> installed the latest version again
  • Deinstalled the newest Radeon version (18.6.1) back to 18.5.1

This is the described behaviour at the moment. I seriously need some help here - thank you very much!

Only just now I realized I have the same problem @qaywert has in this Topic

Downgrade to piplay The latest version a lot if folks are having connection issues.

I already did this. Unfortunately no difference…

@Kalyi please use 17.2.1 version of driver to connect.
if it is still the same, please send the teamviewer id and password to me.
i will be available at 10:00 to 18:00 Beijing time.
you could use the latest version of piplay to connect.

1 Like

this is a knowed issue if you are running whit an old razer keybord, just unlpug the keybord - wait for piplay to find the headset - plug keybord back in

worked for me atleast

1 Like