Star Wars: Squadrons First Impressions In The Pimax 8KX + YAW VR Motion Simulator Live Replay!

Oh man I have been waiting for this for what seems like forever but it is finally here… Star Wars Squadrons has officially launched now and I can’t wait to get into my X-Wing and live out more of my childhood fantasies in Virtual Reality! I tried to stream my raw first impressions of the game last night but as many others did, I had a terrible time getting through the failed EA log in process for Origin due to an old password and email that I had long forgotten and some really bad default HOTAS support so needless to say as much as I had been looking forward to this game… the first night with it was a complete sh** show… Thanks EA! []-/.

Flash forward 24 hours and I have now set the HOTAS up properly in the game and thanks to the Sim Racing Studio Team I even have Joystick tracking for the YAW motion simulator working now, so I guess it was worth the wait to play it again tonight… Technically It’s still my first impressions since the first attempt last night was pretty much a dud! So hopefully tonight’s attempt to stream Squadrons is way less stressful! I will try to check the chat from time to time during this stream so please let me know what you think! OH and for anyone who was here for last nights stream I want to apologize for my horrible attitude and comments… needless to say I was just really let down by this first night experience for this game than I should have been but either way, I’m playing it properly now and that’s all that counts! []-)

If you are interested in the hardware I am using in this video you can get more information from the websites below:

Pimax 8KX Headset:

YAW VR Personal Motion Simulator:


I’m having problems with the opening videos (after selecting a pilot) - they play 1 inch from my eyes and follow me when I try to back away or turn my head. How did you resolve this?

1 Like

How did you get it to run? I can’t get past a blurry EA login page that won’t respond to mouse clicks.
I can’t get Pitools to allow me to set it up for VR, and although it shows up in the game library in pitools after importing, it doesn’t seem to run.
What am I doing wrong- and remember, there’s no mistake so stupid that I can’t make it.

I managed to get passed that EA login by starting the game first on desktop mode. Loged in, got to the main menu then exited the game and restarted it from SteamVR.At this point, I was already logged in.


AHA! Good thinking! I’ll give that a try.

Ok… that seemed to work at first, but then I got dumped to the VR spiderweb steam screen with no way back.


ok Try that just for now:

  1. Close Steam VR and shutdown HMD.
  2. Load the game desktop mode.
  3. With the game open, boot your HMD and start steam VR.
  4. Once everything is loaded, go back to SW:Squadron and go Option, Display, Toggle VR (Something like that).

At this point, your game should transition display to your HMD and you should be able to see it. Give it a bit of time, this game’s still really buggy.

Note that for now, you need PP On to play it properly.

I dont’ have enough frmaes in 8kx in native, have to use upscaled mode, but then my right display turns off after like 10-20 minutes.

I don’t know if this helps but maybe. I jump straight into VR, I don’t switch modes. The only time I used desktop mode was on first launch so I could configure desktop res and set up the HOTAS so I could then run it purely in VR afterwards.

Currently method:

  1. I don’t use the EA login and don’t get prompted for it. It just uses my Steam account and loads automatically.
  2. I start by going to PiTool, applying my Squadrons profile, and then hitting Start on PT. I then have my headset ready to put on. PT will launch SVR, and then the game.
  3. Once launched it goes straight to the intro movie. You can skip this with a trigger press, or I think mouse click or space bar.
  4. Then you’ll hit the main menu.

Desktop starts off in the wrong resolution and misses the buttons on my 1440p monitor. So I would ignore VR on first load, get that switched, use spacebar as OK if you can’t see the ‘OK’ button and go from there.

I’ll guess for that blurry login screen it’s a res issue. Just Googled it and that seems to what others thing and workaround too. Try to login and hit spacebar I guess?

“I managed to log in. Just go into the settings and restart the game in windowed mode. The Log In Prompt match the screen resolution now.”

I actually set to fullscreen at first so it then let me choose the resolution. Since then I set it back to Borderless because many people reported VR problems, if desktop mode is not set to that.

A lot of people report crashes to desktop when either Volumetric Detail or Volumetric Detail VR is set to anything but Low. I had that when trying several game modes, and setting the VR one to low solved it for me so far.

Final thing, there shouldn’t be any need to manually import Squadrons, or any Steam game into PiTool. They are picked up automatically. If it doesn’t appear after installation, quit and restart PT or restart the service. Perhaps it wasn’t imported correctly and that’s why you can’t launch from PT.

Well I got it working. Once again it’s because I’m not that smart. I hope and pie tools and left it alone and then just started it from the steam library screen. That worked really well. Then I spent the next hour trying to figure out how to change the joystick axes so that left/right stick controlled roll. The default sets roll to the Z axis which is normally throttle. Gor blimey… have the developers never played a flight sim?
Ah well it looks great- and even in my old 1080 it seems fairly smooth.
Thanks for all the help guys!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.