Some controller Compatibility issues with Index controller (Some Info)

I got good length usb-c cables and some arm band to test your temporary solution more easily. I’ll try this tonight.


I noticed in Half Life Alyx, that my left Index Controller randomly looses tracking for 0,5s @ a time. Maybe this is correlated.


Yes this is exactly what we’re all discussing. It’s not like obvious tracking issues, just a drop out for a half second then it comes back every couple minutes.

It’s playable in most games, but for something like beat saber that will ruin gameplay. I also find it immersion breaking as hell for 300 dollar controllers.

Last night I used the base station console to unpair all controllers, re pair them in pitool, I checked the sensor count of the hmd and both controllers to check for a defective sensor, disabled all programs but pitool and steamvr. Nada.

Im worried this is due to an ic in the headset losing connection to the controller, because that may be an actual hardware issue, which would be utterly unacceptable since they sell the things. But hopefully it can be fixed in software

1 Like

when I received my index controllers and LH’s from Valve, they worked flawlessly for a long time (weeks). But suddenly the right controller started loosing tracking yesterday. It’s very strange, I can’t pin it on a specific PiTool version or Firmware, but SteamVR has been updated several times over the past week.
utterly strange, will have to go through a few PiTool versions more.



I took 30min during my lunch to test out Beat Saber but with @flynny75 solution.

I can say that I saw no tracking issues at all. Tracking was perfect, the same as when I tried my controllers with an HTC vive’s system.

It is pretty uncomfortable, as you have armbands and 2 usb-c cables connected to the headset. It’s not easy to move, but as soon as I disconnected the usb, the tracking became awful again. I see in the vrmonitor.txt that everything was perfect until that moment when I disconnected the controllers. From that point I saw a bunch of these:

Tue Mar 31 2020 12:28:04.137 - [Status Warning Added LHR-####### Controller(1)] Searching…
Tue Mar 31 2020 12:28:06.136 - [Status Warning Removed LHR-####### Controller(1)] Searching…
Tue Mar 31 2020 12:28:06.136 - [Status Warning Added LLHR-####### Controller(2)] Searching…
Tue Mar 31 2020 12:28:08.137 - [Status Warning Removed LHR-####### Controller(2)] Searching…

So it might be related to the receiver within the pimax headset.

So I’ll ask again. Is anybody with Pimax’s support right now regarding this issue? We need to go through Pimax support to get this resolved.

We’re getting closer :slight_smile:


Tested only one usb-c in right index controller, and fix the tracking issues in both controllers testing beat saber.

After unplugued the cable in 5 minutes more or less return the tracking micro cuts issues…

Yes we’re getting closer


I’ve been having this issue as well. I don’t recall it happening much when I first got my knuckles and with pitool .245, but 255 and 258 they disconnect and both shoot to the floor. I’m going to try rolling back to 245 and see if that helps

I may have found a “solution”. And I only call it a “solution” with quotes, because it is still not acceptable to be restricted on headset features like this, especially with a PC build like mine. So you guys had me thinking when you brought up how there could be just too much traffic on the headset’s one USB cable so I thought about how I could lessen that traffic. I lowered the refresh rate and it seems that my issue is now “basically” gone. Still drops on occasion, but I can play beatsaber Expert+ songs now. I only tested this for one play session, so it could have just been a lucky play session. If anyone else gives this a shot, let me know how it goes for you.

If this does work, this is still unacceptable and this issue still needs to be fixed. I shouldn’t have to drop the refresh rate if my PC is more than capable of handling it.

@zomb1e Let me know if that works for you. I’d rather roll back than have to lower my refresh rate settings.


Very interesting. I’ve been playing 120hz exclusively, I’ll try 72

1 Like

Same, 120hz as well… might go to 90hz and test.
but, i really want to use 144hz once they fix the profiling on it…
dont want to be limited to 90hz or lower just because an issue with the bandwidth on the Headset.

i’ve been playing Alyx on 90hz prior to today. i just bumped it up to 120hz and my index controller performance seems to be about the same. also, i tried using my Vive Link Box again but this time connecting it to the USB port that was alone on it’s own controller and i have the same performance as when plugging the Pimax directly into this USB port.

i have not tried 72hz yet though.

If correct this would explain my lack of issue as I always play at 72. if 90 is ok it will make some of those denied 120 feel a little less left out. :grinning:

1 Like

unfortunately this didn’t solve the issue for me. At first it seemed better - solid 6 or 7 minutes with no dropouts, then they started up. It always seems to behave this way. As someone else mentioned, restarting the HMD will give you more time with no tracking loss again. Doesn’t really give an indication of hardware or software issue though… I was hoping 72 Hz would do it as it would clearly show it’s a bandwidth limitation, but not for me

i have a 203 serial in case that’s relevant.

@Leonardo @Heliosurge
i saw in the other thread that Lenoardo already opened a ticket with support on this. should we all open tickets anyway or are they already tracking that this is a widespread issue?


It might be an idea.

@Alex.liu are you aware ofvtye tracking issues described here?

1 Like

I’ve had a ticket open with this issue since i got it november.
then made a new one last month as well for a direct link to these before.

Been with Steam RMA support at the same time as here(pimax support email), posting everything i did and what i could find(still have not got a reply though for the past 4 days).

the only time my issue does not arrive, is when it’s plugged into a USB port for the controllers.

and that is NOT ideal, Means that there is not enough bandwidth in the headset for the controller to both use.

the only thing i can think of as an ALT is to get a Vive tracker dongle or a steam controller dongle(then convert that to a watchman) then pair it to them… the thing is… i CAN’T find them anywhere anymore.
the time i was in the surgery/hospital all December, they had a Final sale for the steam controllers…

Been looking for at least 2 dongles, that would help a lot.
Not only could i try to have this issue fixed for my index controllers, i could try to use my vive wands as trackers as well(been reading that after trying for a solution for index fix).


these things claim that they work with the Steam controller. what’s the chance that these can be converted to watchman?

i’m not too familiar with the Steam controller. does it just support multiple modes: normal Bluetooth and it’s own thing?

also, just found this:

Doman Chen’s last message said he was bringing this to the R&D team, so I’m not sure how responsive they are. There’s 2 scenarios here:

  1. I am the only one with the ticket open. They might threat it as an individual case and not care about widespread fix.

  2. We all create ticket, it will get attention but slow down the support process because we made to much ticket about this.

I might suggest that 3 or 4 of you guys create tickets and all relate to the 2 major threads on this forum about tracking issue.

1 Like

Or have one thread where everyone afflicted can post much information about the hardware and software they are using like was done with the stutter issue.
Although when Pimax did address that one they didn’t bother saying what was causing it and why only certain people were affected, like this one.