[SOLVED] Pimax 5K+ Tracking bugged out? Headset appears behind the basestation?

I don’t know what happened, but suddenly the tracking of my Pimax 5K+ is buggy and I’m not able to fix it. First I thought it was a tracking issue with my Vive controllers since both controllers appear a few meters away from my headset position, but after going into the Roomscale Setup from Steam, I noticed that the position of my Pimax 5K+ is completely wrong. Please check the picture below:

As you can see the headset position is getting tracked on the opposite side of my controllers…it’s even showing that my Pimax HMD is BEHIND my basestation, which would make tracking impossible.

I tried to reboot my whole PC, recenter, re-run Room Setup in PiTool and in Steam a couple of times, even reinstalled PiTool and SteamVR, but nothing helped. I also tried to switch to “Seated” instead of “Roomscale” in Steam, but the issue remains. So what is going on?

1 Like

@Sallwitz might have some insights?


I fixed it! I manually deleted the “lighthouse” folder in this path and it’s working again:


1 hour of troubleshooting thanks to some weird bugs in PiTool. This software is a mess…unfortunately.


Yap, thats it. glad you fixed it too. I did it a bit more complicated and at last with the help of @Douglaster i could fix it. But sometimes definitely weird stuff is happening with the room tracking software stuff.
I had my controllers glued together after i put em down for a few minutes. and then they were working as one controller together, but both different functions of buttons were executed when pressing only one button on a controller. So one button triggered the functions from both controllers. rebooting controllers and restarting the app helped.