[Solved] Overlays flicker with 8KX but not 8K+

I just received my new 8KX and am having an issue in iRacing. I use a program called CrewChief to insert 2 windows into VR as overlays. This has been working without issue for the last year on an 8K+, however now that I have installed an 8KX the overlays flicker, as well as the rest of the screen (looking at it I believe it is not the hardware flickering but appears more like something rendered into the video source). The issue seems to be impacted by the rendering complexity of the scene, for example if my view is made up of mostly the track and sky (a limited number of simple to render objects) the flickering largely goes away, but in areas where many objects are being rendered the flickering is more of an issue. The problem is only in native mode and not in upscaled mode. I also get flickering when the FPSVR overlay is loaded and not other overlays are present (I don’t normally run FPSVR but this was my test to see if CrewChief was the cause). Initially I wondered if the issue was not enough video memory, but I reduced the texture quality with no noticeable impact.

My current belief is that this is software not hardware and that it is in some way related to the resolution being rendered.

I’m running PiTool 1.01.271, and firmware 2.1.255.297

My PC is an AMD 5900x, with a nVidia 3080 (most up to date drivers). and I have 64GB of system memory. My FPS rates are not below the 75hz refresh rate of the Pimax at any time whether experiencing he flickering of not.

Thanks in advance for your help and guidance.

It sounds like the frame is being shown before it is fully rendered.

Try changing the “Virtual Reality pre-rendered frames” setting near the bottom of the list in the nVidia control panel. It defaults to 1, so try “Use the 3D application setting” first and if that doesn’t work try 2 (or even 3, if necessary).

Following this up.

I tried changing the “Virtual Reality pre-rendered frames” which did not seem to make a difference.

I spent bunch of time working on this and found the following. The issue seems to be tied to the per eye resolution, meaning the issue is:

  • present in native mode at 1 render quality (Steam VR resolution = ~5k x 3k)
  • not present in native mode at 0.75 render quality (Steam VR resolution = ~3.5k x 2.1k)
  • not present in upscalled mode at 1 render quality (Steam VR resolution = ~3.5k x 2.1k)
  • present in upscaled mode at 1.5 render quality (Steam VR resolution = ~5k x 3k)

Subsequent to that I determined if I lowered the render settings slightly (turned off HDR and Soft Particles) within iRacing the flickering went away even in native mode with a 1 render quality. The issue appears to be resolved.

While I was testing the iRacing render settings I noticed something strange, there appears to be a performance cliff which I’ve never noticed before (I may not have been taxing the GPU this highly in the past). Setting being below (less complex) the threshold I have no issues (90fps and no flickering), then as I turn up the iRacing quality settings I get overlay flickering (90fps and flickering of overlays), and then if I push slightly further the FPS drops off a cliff and SteamVR starts crashing regularly (2-4FPS, SteamVR crashes). The strange thing is the difference in settings between these 3 settings is very minor, if I turn off Soft Particles, the FPS goes from 4FPS to 90FPS, and if I turn off HDR the flickering goes away.

Anyway I’ve happy that the original issue is resolved and post this last part for information and interest.

2 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.