[Solved - maxRecommendedResolution issue] Problem with Pimax 8K+ on iracing

just got my headset and when in iracing, my dials in the car are all blurry, everything else seems nice and sharp etc… pls help, what am i not doing correctly!


The problem is that a SteamVR default setting is too low for wide FOV headsets, especially when Parallel Projections is enabled in PiTool.

The issue is complicated by the fact that the location of the SteamVR settings file varies, depending on your system. You can find more details by searching this forum for maxRecommendedResolution, but the essential details are…

You need to add or change the following line in the file. I use 12288, but 8192 and 16384‬ have been used by others with success.

"maxRecommendedResolution": 12288,

For reference, my steamvr.vrsettings file looks like this, but don’t just copy this, since those settings are customised for my system. The line you care about is 6 lines from the bottom…

   "DesktopUI" : {
      "pairing" : "1533,838,800,600,0",
      "settings_desktop" : "1929,867,800,600,0"
   "GpuSpeed" : {
      "gpuSpeed0" : 1035,
      "gpuSpeed1" : 1025,
      "gpuSpeed2" : 1024,
      "gpuSpeed3" : 1025,
      "gpuSpeed4" : 1022,
      "gpuSpeed5" : 1021,
      "gpuSpeed6" : 1020,
      "gpuSpeed7" : 1021,
      "gpuSpeed8" : 1021,
      "gpuSpeedCount" : 9,
      "gpuSpeedDriver" : "",
      "gpuSpeedHorsepower" : 1022,
      "gpuSpeedRenderTargetScale" : 1.5,
      "gpuSpeedVendor" : "NVIDIA GeForce RTX 2080",
      "gpuSpeedVersion" : 2
   "LastKnown" : {
      "HMDManufacturer" : "Pimax VR, Inc.",
      "HMDModel" : "Pimax 8K"
   "steamvr" : {
      "background" : "#FF000000",
      "enableHomeApp" : false,
      "installID" : "9155855521027359162",
      "lastVersionNotice" : "1.11.11",
      "lastVersionNoticeDate" : "1587179453",
      "maxRecommendedResolution" : 12288,
      "showAdvancedSettings" : true,
      "showMirrorView" : false,
      "supersampleManualOverride" : true

thank u so much for the prompt reply… i am a total PC noob here… mac user! haha!
please tell me exactly what and where do i do this… gosh i am so sorry!


No problem. This has hit Pimax users again and again.

  1. First determine which directory your steamvr.vrsettings file is stored in.
  2. Use NotePad to edit the file
  3. Find the “steamvr” section of that file
  4. Find the maxRecommendedResolution and change the number. I use 12288. The problem with a too-large value is that SteamVR will let you set your super-sampling resolution up to that max, which can causes crashes or major slowdowns in your VR apps. If your video card has less memory than my RTX 2080 (8 GB), you should probably use 8192.
  5. That line might be missing. If so, you will need to carefully add it in the right section of the file.
  6. Make sure you format the line exactly like the line below, including the "s and the trailing , (comma).
  7. Save the file and exit NotePad.

“maxRecommendedResolution” : 12288,

Since you’re new, you only need to enable Parallel Projection for some apps which don’t directly support angled VR panels. If you see double images in a game, you need to enable PP. There’s a spreadsheet which lists games and compatibility settings. I’ll go look for it and post a link in this thread.

Note that it’s possible that you have some other issue, but this is the most likely problem.


Neal, dude… thank u so much… it worked!!! thank u! now i got another question… am only doing 40fps on iracing… what am i not doing right?


Great! I’m glad I could help.

I’ll need to know more about your system, but you need to be aware that VR is very demanding and you often need to tweak settings in PiTool and/or SteamVR and/or the in-game settings to get optimum performance.

My system is an i7-8700K, 32 GB, RTX 2080.

Here’s a free program that can help identify any issues or bottlenecks in your system. It identified a RAM configuration in my system, which gave me about a 20% framerate increase and has helped many others on this forum. When the benchmark completes, it will display your results on a web-page and provide helpful hints to fix any problems. Look for the gray-circle (?) icons and click it for more info.


Here a link to the game spreadsheet topic…

For comparison, here’s my results…


In addition, I recommend a GTX 1080 Ti, RTX 2080, or 2080 Ti. Lesser GPUs will work, but you will need to reduce your graphics settings for acceptable performance. I recommend using Normal FOV in PiTool, since the additional res for Large FOV incurs a significant performance reduction.

Only use Parallel Projection if needed, since it requires rendering a larger image which incurs a significant framerate reduction.

In PiTool, Smart Smoothing and FFR (Fixed Foveated Rendering) options can help boost your framerate. FFR is only available on RTX 2000 series cards and reduces the resolution of the outer area of your view. I only use Conservative or turn it off, since it can be annoying. Also FFR does not work in all games; the usual problem is the res for the right eye is too low. I don’t care for Smart Smoothing, which can cause weird visual artifacts in some games.

If you have an AMD GPU, you should search this forum for tips.


i only use 3668x2264 in steamvr, large fov and parallel projections off. have to use 4x aa in the game though for it to look good

how do u do those settings? am not PC savvy :frowning:

here’s my specs

Hi Geoff,
Everything probably is going to depend on your graphics card model/ cpu
Can you advise?
Then some people may be able to point you in the right direction for Iracing settings,
you may have run the automatic graphics setup in iracing first, then either turn up or down the settings to get a decent framerate.
best of luck

1 Like

hi darren,

jujst posted my com specs above… :slight_smile:

What is your CPU and graphics card? Something is clearly amiss, since your PC Status is so low. You should go through the full benchmark results and see if there are any specific issues and recommendations.

Also, your RAM speed appears to be low. Is it fast “gamer RAM” or just something inexpensive?

I noticed the that your Background CPU is at 11%. You should close all your other apps, prior to running the benchmark. If you did do that, you probably have too many background apps running. If this is a new, pre-configured system, it may have a bunch of “bloatware” installed, which you should probably uninstall.


I can t see the graphics card model…but looks ok.
FWIW heres mine 2080, 90fps on large

pimax pitool at 1.0, only hidden area mask ticked

I cant run much more than this on large.

sharpening in the iracing setup really improves the 8K+

You have a great system. (Better than mine.) That’s standard speed RAM, which is why the speed was lower than expected (considering your other components are top-notch).

Your system appears to be under-performing, but I’m sure our forum members can help. That’s assuming you were only running the benchmark and no other apps at the time. Also, you might want to double-check your RAM specs. If you have faster RAM, you need to configure it in the system BIOS.

If you post the full benchmark URL (web address) for your specific result, I can give more advice.

It’s well past my bedtime, so I’ll let others help for now. Otherwise, I’ll check back tomorrow.

so that said Neal… what do i do next to better my headset for iracing? :slight_smile:

Make sure no other apps are running, rerun the benchmark and post the full benchmark URL of your result.

As for game-specific tweaks, that’s not a game I play. You might want to post a separate thread in the Games subforum, asking for iracing setting suggestions. There might even already be helpful posts there.

Incredibly useful and interesting information. Thanks for sharing. I’ll try that benchmark test myself later, didn’t know such a thing existed.

1 Like

There are other, more specialised benchmarks, but I like that one for diagnosing PC issues. It can also make upgrade suggestions.