[SOLVED] hopefully ;) - LED stays white, error 10600, 8K-X brick? Or is it just the DP-cable? Any further ideas?

Okay… seems as if either the upgrade to .275 and downgrade back to .270 did mess up something.
Or after two years, my 8K-X just refuses to work… :disappointed:

=> When I wanted to start a VR session one hour ago and launched PiTool, I got error 10600: HDMI/DP not connected.
I shut down the HMD by button, switched it on => no change.
I restarted PiTool service with the in-PiTool menu button => no change.
I soft-rebootet my PC, started PiTool => no change.
I changed USB-port on my PC => no change.
I changed DP-port in my graphic card => no change.
I changed both ports USB and DP at the same time => no change.
I started getting a little bit nervous…

I noticed once again very conciously that the HMD’s LED is always shining white (might also be something like very very yellowish light-green - I just call it white) when on (instead of dim red), since I did the upgrade to .275 and the corresponding firmware version… but okay - three days ago, it did this, too, and it was still working.
Not today…

I decided reverting to the former firmware version m295 from January 2021.
=> Unplugged the 8K-X.
Connected it to my convertible, switched it to DFU mode, flashed m295. Everything fine until there. Except the LED still was shining white when on… and not dim red.
Replugged it to my PC, started PiTool => no change.
Powered the PC off, rebooted => no change.
Uninstalled PiTool .270 and reinstalled => no change.
Once again tried changing DP-port since 10600 mentions HDMI/DP connection issue => no change.
Unplugged the DP cable from the HMD and reconnected it to ensure it plugs in firmly => no change.

… so …

… finally I don’t have any idea what to do else…

Is the headset itself completely brick?
Did the firmware upgrade for PiTool .275 break something? Since the LED never was shining that yellowish-greenish white before?
Or might it just be the DP-cable…?
At least, Windows seems to recognize something via USB because when I push the volume buttons on the HMD, I see the volume control changing on my monitor.
And according to error #10600 it really “just” might be related to a defective cable. It is still the initial first one, and just because I did not have any issues with it so far like others had, it is not said that I am not getting them right now…

I had a handful of 10600’s in the past as well with .270 and firmware m295 - but I was always able to solve them latest by rebooting, and the LED was never shining white.

Now - I just did the test once again right now -, the following happens:

  1. 8K-X is off. LED is bright red.
  2. I switch it on by pressing the button.
  3. 8K-X starts, LED shortly shines dim red, then (1s later) it goes white and stays white.
  4. I launch PiTool
  5. PiTool welcomes me first with #30000, then goes over to #10600 and stays there.

Normally - in the past - when I launched PiTool, the 8K-X was recognized instantly - no 30000, 10500 or 10600 except 10600 on this handful occasions as mentioned above.

Any help is really appreciated. I am not yet in a panic :wink: but having a 1000$ brick headset isn’t very fun either… I like it so much and just want to drive or fly around with it :sob:

Thanks :slight_smile:

Okay… it gets really weird and annoying now:

As last try I decided to forward to PiTool .275 and firmware 299 again:

  • Uninstalled .270 and cleaned everything (as always)
  • Unplugged 8K-X from my PC
  • Connected it to my convertible and entered DFU mode
  • Flashed 299
  • Installed .275 to my PC
  • Rebooted
  • Reconnected the 8K-X to my PC
  • Launched PiTool

… and the 8K-X was recognized instantly and providing image :slight_smile:

Honestly, I still don’t know whether the solution really was upgrading again.

But if so:
Please be aware that apparently moving to .275 and 299 might be a way of no return, perhaps.
Of course, I don’t know why the HMD first worked in the combination .270/299, too.

But as said above: Something really is strange here:

  • Having it work with .270/299 three days ago,
  • today trying to get it work with .270/299 and .270/295 without success for an hour,
  • and then over a sudden getting it work with .275/299 again

… isn’t really satisfying - except the fact my 8K-X isn’t brick, of course :wink:

And it doesn’t really provide confidence to this latest PiTool and firmware versions…
It just might be .270 isn’t fully compatible with firmware 299 - and doing a fall-back to firmware 295 doesn’t seem to work properly, too… which, honestly said, is a common issue with many firmware and BIOS downgrade flashing, I know. Although I cannot understand fully, just why…? :thinking: What’s so difficult with flashing down in general (besides Pimax, but with other hardware and manufacturers, too): Just delete the active version and overwrite it with the desired one, independent from up- or downgrading…? :face_with_monocle: Hmmmm… :thinking:

Nevertheless: May it last now, even, if PIOverlay now always opens in a separate window and probably will create those “pi_overlay.exe not working” errors each time I close PiTool now… :confused:

Good morning :slight_smile:

Just to complete the story with newest information:

8K-X seems to work still :+1:

Though:
I powered on my PC five minutes ago for home office, and the LED of the headset wasn’t dim red as it had been before updating to .275/299, but white-yellowish-greenish again.
I started PiTool for a short try whether the 8K-X is recognized - and it first showed #10600 and really took it appr 1-2 seconds until the 8K-X finally got activated, and then, the LED switched to purple.
When closing PiTool then, the LED switched to the usual dim red :white_check_mark:

Nevertheless, this prooves once again to me that .275/299 isn’t running as smooth and flawless as .270/295 before on my machine, whatever the reason is…

I’ll see whether I’ll give another clean downgrade a try later this day:

  • First, setting the HMD in PiTool to lowest and easiest settings for best downgrade compatibility. (When I first tried .270 with 299 four days ago and started PiTool .270 the first time, the HMD image was showing a flickering snowy B/W screen, and although I changed the HMD to 75 Hz with .275, just downgrading PiTool from .275 to .270 let the HMD switch automatically back to 90 Hz - which of course isn’t supported by .270 yet.)
  • Then uninstalling PiTool and flashing 295 onto HMD again.
  • Installing .270
  • … and see whether it works then and if the last time, just something messed up somehow… just a bit curious how and why the HMD didn’t save the 75 Hz properly and set itself back to 90 Hz just when downgrading PiTool… and curious whether this will happen again today, if I leave .275 with 60 Hz instead of 75…

Really - just wished I’d skipped the upgrade to .275/299 a couple of days ago…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.