(Solved) 5K+ received, setup issues

Received my testing 5K+ today and am sorry to have to say I‘m having issues getting it to run.

Pitool is up to date *.90 and I have also upgraded the HMDs FW to what was included with *.90

Pitool recognizes the HMD, basestations and Vive wands after pairing but Pitool shows that the HMD isn’t tracked.

It is in Lighthouse mode, I have switched modes, rebooted HMD, rebooted PC, switched to SteamVR non beta and have disabled SteamVR safe mode to allow unknown driver loading.

Anyone knows how I could troubleshoot?

@PimaxVR @SweViver

Is the HMD displaying grey/blue color?
Did you try others USB port and unplugging the AC of the HMD? not just the USB


What’s your back number?

1 Like

@spamenigma, @Chucksta might have some ideas as they too had initial setup problems.

Have you looked in the Windows Event Viewer (Right click start button, select it) to see if there is a PiTool or something log message.


I think there is an answer to what to do to get this running, when using base station and controllers. I forget what it is

Helio will know! Probably got a better memory than I have. Hell, everybody will have a better memory than me :smiley:


Unfortunately no base stations so not commited to memory as it’s out my experience.

But bios & ensure chipset drivers are upto date.

I also found if you have Red/org usb ports use them as they are high speed ports.

I am curious though if we could get a usb-c set of cables for those whom have it on mb

1 Like

Yes, Blue/grey when in Lighthouse mode, Pimax Logo when in 3DoF Mode.

Have tried different USB ports including on two high end PCIE USB cards.


I’m not sure why, but when I got the .90 release working after some random plugging/unplugging and rebooting (because you have rebooted at least once already, right?) I thought I was a gonner, but then I put the headset on the ground (in clear view of the lighthouses) and turned on the vive controllers and all the sudden everything remembered how to talk to each other.

Perhaps try pairing your controllers first.


I did successfully pair the controllers but the HMD is either not recognized by SteamVR or in 3 DoF mode.

This is what PiTool and SteamVR are telling me.

Note that the HMD is identified as ‚Vive MV‘, is that the case for all of the Pimax HMDs?


Yep, identified as Vive MV here too :slight_smile:

That’s the only input to this I can do, as I do not have base stations and controllers :frowning:


Please try delete the folder (C:\Users\Administrators\AppData\Local\Pimax\runtime\config\lighthouse),and then restart the PiLauncherService in Service interface of Task Manager.


Thank you so much, that did the trick!!

Ok so I have it up and running and immediately did a quick swap with my Vive Pro wireless: that thing is DEAD to me!!

I honestly can’t overstate how much better the 5K+ looks and feels, at least on first glance for now.

This will be one hell of a VR weekend!


Awesome to hear it did the trick.


Nice i really hope by the time preorder starts all these software issues are fixed


I hope it’s sorted way before that. Lol.

give us some impressions when you played some games please…

I‘d love to but alas the 5K+‘s power LED keeps flashing green as of yesterday and I cannot access the HMD at all. Waiting on Pimax Support for some feedback.

The little time I got in on In Death was fantastic nonetheless.

I will say that the three musketeers @SweViver @mixedrealityTV and @VoodooDE prepared us perfectly with their reviews, I can echo them 1:1

Getting your IPD dialed in perfectly matters more than on any other HMD and once you do, the FOV and improved clarity even from a GearVR lens modded Vive Pro is breathtaking. Period.

I didn’t notice the super small sliver of shimmers in the utmost periphery at FOV normal after about 5 minutes anymore, and that was in a bright game like In Death.

I just hope I can get back to getting into those experiences asap, I’m at least as excited as when I got my 1st wave OG Vive because now there are actual titles I have been saving to experience in this puppy. 10 minutes in an old modded SkyrimVR savegame had me giggling maniacally.


If you are trying to take screenshots your best bet is probable the Snipping Tool (included with windows) or the Print Screen button (copies to clipboard, then paste into Paint/etc). In this case I used the Print Screen button to take a picture of the Snipping Tool (insert Inception noise).

This will usually give you better image quality, lower file size, and easier acces to files (if posting from the same computer).


Yes Withdrawals suck in VR when you have found Shangri la. :beers::wink::+1::sparkles:


Thanks, I’m quite aware.

Thing is, I’m perma logged into this forum on my phone and on my work PC, not my gaming PC. As I have no clue what my pw is and the Pimax reset pw function appears defunct, I had to literally photograph my screen on my phone and upload via that.

1 Like