Small steamVR desktop problems with Pitool update

New pitool update is out, and with it comes a bit of trouble-shooting!
I had two issues after leaving my headset unplugged and installing both nvidia latest drivers as well as pitool, I only removed the USB and display port of the pimax, and left it unplugged until I restarted my computer after all software was mounted.

After everything was installed I plugged in my pimax in and had some small issues with controllers not connecting, and frame lag when the steamVR desktop overlay is open, but only when the overlay is open. It is consistent frame-drops that look like tracking issues where the headset will stick in one place for a frame or two. I have a 1080ti Gigabyte AORUS and headset firmware V2.1.255.193.

HOW TO FIX CONTROLLERS: I basically have this system of restarting my computer, plugging controllers into my computer with steamVR running (as well as pitool) with a data usb (the charging cables that comes with the vive controllers work), and after about 3 minutes unplugging them, this will force sync the controllers. If that doesn’t work, try plugging in the base stations one at a time, setting them to “b” on the front, and plugging it with the same data usb cord AND the power cable, and leave it for the same 3 minutes. Then set them all back onto their base stations and set them back to b and c channels. Next, try pairing the controllers through pitool, then finally re-do room-scale setup from pitool directly, and then do room-scale setup in steamVR. This sequence of steps should fix a wide variety of problems with the headset, in my experience.

Helio, if you could tag the proper people for the steamVR desktop overlay lag report, I would appreciate it. Thank you!

@Sean.Huang @anon74848233 @Doman.Chen


Does this fix headset tracking?

Added to @Davebobman troubleshooting Wiki

Well, it is a very general fix pattern, this should work on most “it was working and now it’s not” stuff. I do know that clicking “diagnose” if the headset isn’t even connecting to pitool, and then telling the service to restart, if for some reason it was stopped.

1 Like

Seems like after the update to I keep getting Not Tracked on HMD but if I use turn off my light house the HMD is detected right away but I can’t use my light house.

1 Like

If it tracked in earlier version of pitool maybe try 111 Beta.

I went back to FW 181 And posted my feedback below. If the official one is buggy not sure if I want to chance it again.

"My setup is 2x give Light houses with rtx 2080 tiwith latest Nvidia drivers. I was previously on [Pitooll v1.0.1.95 FW 181] Which worked ok. After upgrading I can’t seem to ever get the HMD tracking.

I was able to get the HMD recognized if I turn off lighthouse tracking but then my controller and LH would not track. Once I turn the LH tracking I’m back to the HMD not tracking again.

I also tried to remove all Steam USB devices which made my HMD track but then again my controllers and LH were gone.

I went back to FW 181 and everything is back to normal. Any other ideas why the HMD isn’t tracking with the newer version?I tried moving to different USB ports on the new version but everything was recognized except the HMD didn’t track."

What do you mean by “this will force sync the controllers”?

1 Like

I am at the same firmware (v181) and even older PiTool (v1.0.1.91), and do not experience any tracking issues. So it looks like a possible regression in the new firmware and another reason to not upgrade.

1 Like

I mean that it seem to force steam to recognize controllers, most times at least.


I am at the same firmware (v181) and even older PiTool (v1.0.1.91), and do not experience any tracking issues. So it looks like a possible regression in the new firmware and another reason to not upgrade.

I’m just glad that I was able to downgrade and go back to the old version. I hope this gets resolved as I really would like to use the new features and performance enhancements.